Задать вопрос
5 августа, 20:42

Дни недели пронумерованы следующим образом: 0-воскресенье, 1-понедельник, 2-вторик и т. д. Известно, что первое число месяца был понедельник. Определите какой день был в N дату (N<=31)

+5
Ответы (2)
  1. 5 августа, 21:50
    0
    const

    mas:array[1 ... 31] of string = ('Понедельник',' Вторник', 'Среда','Четверг', 'Пятница', 'Суббота', 'Воскресенье','Понедельник',' Вторник', 'Среда','Четверг', 'Пятница', 'Суббота', 'Воскресенье','Понедельник',' Вторник', 'Среда','Четверг', 'Пятница', 'Суббота', 'Воскресенье','Понедельник',' Вторник', 'Среда','Четверг', 'Пятница', 'Суббота', 'Воскресенье','Понедельник',' Вторник', 'Среда') ;

    var

    i, n:integer;

    begin

    writeln (n) ;

    for i:=1 to 31 do

    if (i=n) then writeln (mas[i]) ;

    end.
  2. 5 августа, 22:18
    0
    var a:array[0 ... 6] of string = ('voskresenije', 'ponedelnik', 'vtornik', 'sreda', 'chetverg',

    'pjatnica', 'subbota') ;

    var c:array[1 ... 31] of string;

    var b, N, i:integer;

    begin

    b:=1;

    for i:=1 to 31 do begin

    c[i]:=a[b];

    inc (b) ;

    if (b=7) then b:=0;

    end;

    repeat

    write ('Vvedite N: ') ;

    readln (N) ;

    until (N<=31) ;

    writeln (c[N]) ;

    readln;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Дни недели пронумерованы следующим образом: 0-воскресенье, 1-понедельник, 2-вторик и т. д. Известно, что первое число месяца был ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Обозначим дни недели числами от 1 (понедельник) до 7 (воскресенье) соответственно. Известно, что первое число текущего месяца поподает на понедельник. На вход программе подается целое число 1
Ответы (1)
Решить 2 задачи в C++ 1. Дано трёхзначное число. Вывести вначале его последнюю цифру (единицы), а затем - его среднюю цифру (десятки). 2. Дни недели пронумерованы следующим образом: 1 - понедельник, 2 - вторник, ...,6-суббота, 7 - воскресенье.
Ответы (1)
На Паскале помогите написать Дано целое число k (1
Ответы (1)
Если это день не идет за вторником и не перед пятницей, а завтра не понедельник и вчера был не понедельник, а послезавтра будет не воскресенье и позавчера был не четверг, что это был за день?
Ответы (2)
Известно, что 1 число месяца-день недели среда. Составить программу, которая после ввода любого числа в этом месяце выдаёт какой это день недели
Ответы (1)