Задать вопрос
18 мая, 05:52

Лыжник пробежал в 1 день 10 км, каждый следующий день он пробегал на 10% больше. Определить в какой день он пробежит 20 км, в какой день суммарны пробег превысит 200 км

Решить в Паскале

+5
Ответы (2)
  1. 18 мая, 07:52
    0
    var

    s, s1:real;

    k:integer;

    begin

    s:=10;

    k:=1;

    while s<20 do

    begin

    s:=s*1.1;

    k:=k+1;

    end;

    writeln ('в ', k,' день он пробежит 20 км') ;

    s:=10;

    s1:=10;

    k:=1;

    while s<200 do

    begin

    s:=s+s1*1.1;

    s1:=s1*1.1;

    k:=k+1;

    end;

    writeln ('в ', k,' день суммарный пробег превысит 200 км') ;

    end.
  2. 18 мая, 07:53
    0
    Может кто перепишет на паскаль

    Вот на C:

    #include

    int main (void)

    {

    int km, day;

    day = 1;

    km = 10;

    while (km < = 200)

    {

    if (km = = 20)

    {

    printf ("20km in %d day/n", day) ;

    }

    km + = km / 10;

    day++;

    }

    printf ("<200km in %d day", day) ;

    printf ("/n") ;

    system ("pause") ;

    return 0;

    }
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Лыжник пробежал в 1 день 10 км, каждый следующий день он пробегал на 10% больше. Определить в какой день он пробежит 20 км, в какой день ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Помогите записать задачу в Turbo Pascalе Начав тренировки, лыжник в первый день пробежал 10 км. Каждый следующий день он увеличивал пробег на 10% от пробега предыдущего Определить: а) В какой день он пробежит больше 20 км б) В какой день суммарный
Ответы (1)
Помогите написать на паскале Начав тренировки лыжник в первый день пробежал 10 км. Каждый следующий день он увеличивал пробег на 10% от пробега предыдущего дня. Определить пробег лыжника за второй, третий, ..., десятый день.
Ответы (1)
Написать программу на Паскале. Начав тренировки, спортсмен в первый день пробежал 10 км. Каждый следующий день он увеличивал пробег на 10% от пробега предыдущего.
Ответы (1)
Начав тренировки, лыжник в первый день пробегал 10 км. В каждый следующий день он увеличивал длину пробега на 10% от предыдущего дня. Определить, в какой день он пробежит 20 км. Составить программу в паскале. (Оператор Цикл. Цикл с предусловием.)
Ответы (1)
Написать код в программе C#: 1 задание: Начав тренировки, лыжник в первый день пробежал 7 км. Каждый следующий день он увеличивал пробег на 12% от пробега предыдущего дня.
Ответы (1)