Задать вопрос
8 апреля, 08:06

Дано натуральное четырехзначное число n. Найти сумму его цифр.

+2
Ответы (2)
  1. 8 апреля, 09:52
    0
    var a, b, c, d, x, res:integer;

    begin

    readln (x) ;

    a:=x div 1000;

    b:=x mod 10;

    c:=x div 100 mod 10;

    d:=x mod 100 div 10;

    res:=a+b+c+d;

    writeln (res) ;

    readln;

    end.
  2. 8 апреля, 10:41
    0
    Паскаль же?

    var s, x: string; c, n, err, i, d, k:integer;

    begin

    readln (s) ;

    n:=length (s) ;

    for i:=1 to n do

    begin

    d:=d+k;

    val (s, k, err) ;

    end;

    write (d) ;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Дано натуральное четырехзначное число n. Найти сумму его цифр. ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Дано натуральное число: определить а) количество цифр в нем б) сумму его цифр в) произведение его цифр г) среднее арифметическое его цифр д) сумму квадратов его цифр е) сумму кубов его цифр ж) его первую цифру з) сумму его первой и последней цифр
Ответы (1)
Помогите решить! 1) Дано натуральное трехзначное число N. Определить сумму и произведение его цифр. 2) Дано натуральное трехзначное число N. Найдите число, образованное перестановкой цифр исходного числа в обратном порядке.
Ответы (1)
6.22) Дано натуральное число. Определить: а) количество цифр 3 в нем; б) сумму его цифр, больших пяти; в) произведение его цифр, больших семи; 6.26) Дано натуральное число. а) определить его максимальную цифру. б) определить его минимальную цифру.
Ответы (1)
Помогите составить программу на языке С! С клавиатуры вводится целое число. Определить кол-во цифр в нем, сумму его цифр, произведение его цифр, среднее арифметическое его цифр, сумму квадратов его цифр, сумму кубов его цифр.
Ответы (1)
Помогите написать программу Паскаль, очень прошу, вообще не шарю в программах, а так 2 поставят! Задача "A": Ввести натуральное число и найти сумму его цифр. Пример: Введите натуральное число: 12345. Сумма цифр 15.
Ответы (2)