Задать вопрос
27 сентября, 18:37

составить программу вычисляющее наибольшее из 3 заданных чисел (паскаль)

+4
Ответы (2)
  1. 27 сентября, 18:45
    -1
    var

    a, b, c, m : integer;

    begin

    read (a, b, c) ;

    m : = a;

    if b > m then m : = b;

    if c > m then m : = c;

    writeln (m) ;

    end.

    ps так корректнее, потому что в первом ответе не учтено равенство чисел.
  2. 27 сентября, 20:38
    +1
    var

    a, b, c:integer;

    writeln ('a, b, c') ; readln (a, b, c) ;

    if (a>b) and (a>c) then writeln (a) ;

    if (b>a) and (b>c) then writeln (b) ;

    if (c>b) and (c>a) then writeln (c) ;

    end;

    можно через один if.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «составить программу вычисляющее наибольшее из 3 заданных чисел (паскаль) ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Ввести слово и число раз (Ввод; паскаль, 3). Вывести это слово так: паскаль паскаль паскаль паскаль паскаль паскаль
Ответы (1)
Помгите! Программа Паскаль Вопрос 1. Функция служебного слова Var. Вопрос 2. С какими числами можно работать в программе Паскаль? Вопрос 3. Оператор ввода. Как он записывается в Паскаль? Вопрос 4. Функция служебного слова Const. Вопрос 5.
Ответы (1)
Задача_1: Составить программу на языке Паскаль для вычисления выражения y:=sqr (x) + x/3+sqr (sin (x)) Задача_2: Составить программу на языке Паскаль для вычисления площади треугольника по трем сторонам (подсказка: это формула Герона) Задача_3:
Ответы (1)
Написать программу на Паскаль: 1) Составить программу, которая при заданных значениях x и y вычисляет функции A с точностью 10^-3 A = ((x*y) / (x+y)) / (1+√ (x²-x-4)) ;
Ответы (1)
1. составить программу вывода на экран всех трехзначных чисел, кратных 9. (паскаль, тремя способами) 2. Составить программу вычисления суммы всех трехзначных чисел, кратных 17. (паскаль, тремя способами)
Ответы (1)