Задать вопрос
23 января, 20:35

составить программу вычисления суммы чётных чисел и произведение нечётных чисел от 1 до 10.

+5
Ответы (1)
  1. 23 января, 23:30
    +1
    var i, s, pr: integer;

    begin

    s:=0;

    pr:=1;

    for i:=1 to 10 do

    begin

    if i mod 2=1 then pr:=pr*i;

    if i mod 2=0 then s:=s+i;

    end;

    writeln ('Произведение нечетных чисел: ', pr, ', сумма четных чисел: ', s) ;

    end.

    А вообще это элементарное задание. Неужели вам не объясняли, как такие делать?
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «составить программу вычисления суммы чётных чисел и произведение нечётных чисел от 1 до 10. ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
1) Составьте программу вычисления сумму чисел от 1 до 100. 2) Составьте программу вычисления произведения чётных чисел от 1 до 10. 3) Составьте программу вычисления количества двухзначных нечётных чисел.
Ответы (1)
1) напишите программу, которая спрашивает целое число n и считает сумму целых чисел, Муму чётных чисел и сумму нечётных от 1 до n 2) напишите программу, которая спрашивает целые числа а и b и выводит на экран квадраты чисел от а до b 3) напишите
Ответы (1)
1. Напишите программу вычисления расстояния между двумя точками плоскости. 2. Напишите программу вычисления площади боковой поверхности куба. 3. Напишите программу вычисления площади и гипотенузы прямого треугольника, если известны его катеты. 4.
Ответы (1)
Используя язык программирования Паскаль выполнить задание: 1. Составить программу для вычисления y=38x+231. 2. Составить программу для вычисления M=7x+6y+276. 3. Составить программу для вычисления N=4a2+2xa+8y.
Ответы (1)
Дано некоторое целое число. Написать программу, которая определяет, каких цифр в нем больше четных или нечетных. Кроме того, сформировать из данного числа два новых числа. Первое должно состоять из нечетных цифр исходного числа, а второе из четных.
Ответы (1)