Задать вопрос
10 февраля, 20:17

составьте программу, которая организует ввод массива а[1 ... 10] с клавиатуры, затем преобразовает массив, заменяя все отрицательные элементы их модулями.

+1
Ответы (1)
  1. 10 февраля, 20:58
    0
    var a:array[1 ... 10]of integer;

    i:integer;

    begin

    for i:=1 to 10 do readln (a[i]) ;

    for i:=1 to 10 do

    if a[i]<0 then a[i]:=abs (a[i]) ;

    writeln;

    for i:=1 to 10 do write (a[i],' ') ;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «составьте программу, которая организует ввод массива а[1 ... 10] с клавиатуры, затем преобразовает массив, заменяя все отрицательные ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Составить программу, которая организует ввод массива a [1 ... 10] с клавиатуры, затем преобразовывает массив, заменяя все отрицательные элементы их модулями.
Ответы (1)
Помогите составить программу, которая организует ввод массива a[1 ... 10] с клавиатуры, затем преобразовывает массив, заменяя все отрицательные элементы их модулями.
Ответы (1)
Решить задачи: Задача 1. Составьте программу, которая заполняет массив а[1 ... 10] случайными целыми числами в диапазоне от 1 до 10, затем меняет местами первый и последний элементы. Задача 2.
Ответы (1)
Все задачи делаются в Паскале! 1) Увеличить все элементы массива A на 1. 2) Умножить все элементы массива A на 2. 3) Возвести в квадрат все элементы массива A.
Ответы (1)
1. Возвести в квадрат все элементы массива A. Размер массива и значения элементов массива - произвольные. 2. Увеличить на 4 все элементы в первой половине массива A (считать, что в массиве чётное число элементов).
Ответы (1)