Задать вопрос
6 декабря, 01:50

Дан двумерный массив целых чисел, i=10, j=15; заполняется случайными образом целыми числами от 0 до 100. Определите сколько раз в нём случается элемент со значением Х (Х-задаётся пользователем).

+1
Ответы (1)
  1. 6 декабря, 02:35
    0
    a:array[1 ... 10,1 ... 15] of integer;

    i, j, k, x:integer;

    begin

    read (x) ;

    k:=0;

    for j:=1 to 15 do

    for i:=1 to 10 do

    a[i, j]:=random (101) ;

    for j:=1 to 15 do

    for i:=1 to 10 do

    if a[i, j]=x then k:=k+1;

    write (k) ;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Дан двумерный массив целых чисел, i=10, j=15; заполняется случайными образом целыми числами от 0 до 100. Определите сколько раз в нём ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Дан двумерный массив целых числе i=10 j=15, Заполняется случайным образом целыми числами от 0 до 100. 1) Определить сколько раз в нем встречается элемент со значеием х. х задается прользователем 2) Определить количесво четных элементов массива.
Ответы (1)
Хотя бы 3-4 задачи! 1) Дан одномерный целочисленный массив размерностью N. Найдите количество элементов, которые кратны 3 (5). 2) Дан одномерный целочисленный массив А, состоящий из N элементов. Найти сумму всех четных элементов массива.
Ответы (1)
1. Дан двумерный целочисленный массив. 2. размерность массива задается пользователем. 3. случайные числа генерируются из промежутка (-m, m) 4. m задается пользователем.
Ответы (1)
2. Задать двумерный массив (4 х4) случайными значениями от 12 до 18 включительно. Вывести сумму значений элементов каждого столбца матрицы. 3. Задать двумерный массив (7 х7) случайными значениями от 12 до 18 включительно.
Ответы (1)
1. Дан одномерный массив размерностью 10, заполненный целыми числами, введенными с клавиатуры, и величина N. Отрицательные элементы заменить на N. Измененный массив вывести на экран одной строкой. 2.
Ответы (1)