Задать вопрос
25 января, 19:55

Написать программу. Чтоб вводимое число делилось на 2 пока она не станет 0. И пусть ввыведит все деление)

+3
Ответы (1)
  1. 25 января, 21:39
    0
    Pascal:

    var

    a:integer;

    begin

    write ('Введите число: ') ;

    readln (a) ;

    repeat

    a:=a div 2;

    writeln (a) ;

    until a=0;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Написать программу. Чтоб вводимое число делилось на 2 пока она не станет 0. И пусть ввыведит все деление) ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
помогите1) для того чтобы число помогите 1) для того чтобы число делилось на 30, ..., чтобы оно делилось на 3 и на 10 необходимо достаточно необходимо и недостаточно 2) для того чтобы число делилось на 5, ...
Ответы (1)
Написать программу нахождения суммы чисел от 1 до n. Где n - число, вводимое клавиатурой
Ответы (1)
Написать программу в паскале для вычисления суммы ряда Sn=1+1/2+1/3 + ... + 1/n, где n - натуральное число, вводимое с клавиатуры
Ответы (1)
Помогите, очень прошу составить блок-схему и написать программу, определяющую является ли вводимое число - нечетным и двузначным одновременно Помоему это очень сложно
Ответы (1)
Вычислить произведение четырех натур. чисел, используя только операцию сложения. (Язык пр:pascal) 1) Написать программу (обычную) 2) Написать программу с использованием процедуры 3) Написать программу с исп. функции 4) Написать программу с исп.
Ответы (1)