Задать вопрос
13 ноября, 19:26

Написать программу в паскале для вычисления суммы ряда

Sn=1+1/2+1/3 + ... + 1/n, где n - натуральное число, вводимое с клавиатуры

+1
Ответы (1)
  1. 13 ноября, 21:12
    0
    Var sum: real; i, n: integer;

    begin

    readln (n) ;

    sum : = 0;

    for i : = 1 to n do

    sum : = sum + 1 / i;

    writeln (sum:3:3) ;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Написать программу в паскале для вычисления суммы ряда Sn=1+1/2+1/3 + ... + 1/n, где n - натуральное число, вводимое с клавиатуры ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Составить на паскале программу для вычисления суммы ряда:s=1+1/2+1/3+1/4 + ... 1/n число n вводится с клавиатуры. протестировать программу для n=1, n=2, n=4, n=6. правильность ответов проверить с помощью калькулятора.
Ответы (1)
1. Напишите программу вычисления расстояния между двумя точками плоскости. 2. Напишите программу вычисления площади боковой поверхности куба. 3. Напишите программу вычисления площади и гипотенузы прямого треугольника, если известны его катеты. 4.
Ответы (1)
Помогите решить 3. С клавиатуры вводится четырехзначное число. Получить число, равное произведению его цифр. 4. С клавиатуры вводится натуральное число п. Узнайте в нем количество цифр. 5. С клавиатуры вводится натуральное число п.
Ответы (1)
Написать программу нахождения суммы чисел от 1 до n. Где n - число, вводимое клавиатурой
Ответы (1)
С помощью оператора Readln, writlen, Random составить программу которая будет сравнивать число вводимое с клавиатуры со случайным числом в диапазоне от 0 до 100 результат выводится на экран.
Ответы (1)