Задать вопрос
16 мая, 09:18

Напишите решение в Паскале: массив А заполнен случайным образом ста целыми числами от 0 до 1000, определить имеются ли в массиве повторяющиеся элементы.

+1
Ответы (1)
  1. 16 мая, 10:06
    0
    var

    a:array[1 ... 100] of integer;

    povt, i, j, elem:integer;

    begin

    povt:=0;

    randomize;

    for i:=1 to 100 do

    a[i]:=random (1001) ;

    for j:=1 to 100 do

    povt:=0;

    begin

    for i:=1 to 100 do

    if a[i]=a[j] then

    begin

    elem:=a[i];

    povt:=povt+1;

    end;

    povt:=povt-1;

    write ('Число = '+elem + ' Количество повторений = ' + povt) ;

    end;
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Напишите решение в Паскале: массив А заполнен случайным образом ста целыми числами от 0 до 1000, определить имеются ли в массиве ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Помогите решить задачи 1. Одномерный массив заполнен любыми числами. Заменить отрицательные элементы их модулями. 2. Одномерный массив заполнен целыми числами. Возвести в квадрат элементы, стоящие на четных местах.
Ответы (1)
Тема одномерные массивы Написать программу в паскале: 1. Массив на 15 значений заполнен случайными числами посчитать количество нечетных значений 2.
Ответы (1)
А) Составьте программу, которая заполняет массив В[1 ... 11] случайными целыми числами в диапазоне от - 5 до 5 и преобразовывает его, заменяя элементы кратные 5 на 5, а остальные увеличивая в 5 раз.
Ответы (1)
Все задачи делаются в Паскале! 1) Увеличить все элементы массива A на 1. 2) Умножить все элементы массива A на 2. 3) Возвести в квадрат все элементы массива A.
Ответы (1)
1) Составте программуб которая заполняет массив а[1 ... 10] случайными целыми числами в диапозоне от 1 до 10, затем преобразовывает его, увеличивая все элементы с четными значениями на 1.
Ответы (1)