Задать вопрос
30 июня, 16:53

Какое наименьшее число почтовых марок стоимостью 10.4 и 1 руб. надо наклеить на бандероль, вес которой М грамм? Плата за посылку вычисляется следующим образом: за бандероль весом до 50 г взимается 10 руб., за каждые следующие полные или неполные 50 г - еще по 5 руб.

+5
Ответы (1)
  1. 30 июня, 19:17
    0
    program while;

    var m, s, d, ch, od:integer;

    begin

    writeln ('Vvedit m') ;

    readln (m) ;

    if (m0) then begin

    m:=m-50; s:=10;

    while m>0 do begin

    m:=m-50;

    s:=s+5;

    end;

    d:=s div 10; s:=s-d*10;

    ch:=s div 4; s:=s-ch*4;

    od:=s;

    end;

    writeln ('10-', d,' 4-', ch,' 1-', od) ;

    readln

    end. {делал без проверки в паскале}
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Какое наименьшее число почтовых марок стоимостью 10.4 и 1 руб. надо наклеить на бандероль, вес которой М грамм? Плата за посылку ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Плата за посылку бандероли вычисляется так: за бандероль весом до 50 г взимается 10 р. за каждые следующие полные и неполные 10 г - еще по 5 р. Вычислить плату за бандероль, если известен ее вес в граммах. Надо составить программу.
Ответы (1)
Напишите программу для определения сдачи K руб. после покупки в магазине товара: перчаток стоимостью A руб., портфеля стоимостью B руб., галстука стоимостью C руб. Исходная сумма, выделенная на покупку D руб.
Ответы (2)
Написать программу в паскале для определения сдачи после покупки в магазине товара: перчаток стоимостью а руб., портфеля стоимостью b руб., галстука стоимостью с руб. Исходная сумма, выделенная на покупку d руб.
Ответы (1)
в паскале описать задачу 4) Человек делает в магазине покупки. Определите сколько денег у него останется после покупки в магазине перчаток стоимостью А руб., портфеля стоимостью B руб. и галстука стоимостью D руб.
Ответы (1)
составьте программу для определения сдачи после покупки в магазине перчаток стоимостью а руб. портфеля стоимостью в. р. и галстука стоимостью с р. если на покупку выделено д р. все исходные данные задаются с клавиатуру
Ответы (1)