Задать вопрос
10 августа, 14:11

Дано 4-х значное число. Определить, что больше само число или его перевёртыш.

+5
Ответы (1)
  1. 10 августа, 15:30
    0
    var

    n, a:integer;

    begin

    readln (n) ;

    a: = (n mod 10) * 1000 + ((n mod 100) div 10) * 100 + ((n mod 1000) div 100) * 10 + n div 1000;

    if n>a then

    writeln ('число ', n, ' больше перевертыша ', a)

    else

    writeln ('перевертыш ', a, ' больше числа ', n) ;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Дано 4-х значное число. Определить, что больше само число или его перевёртыш. ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
1) Запишите внутреннее представление десятичного числа - 104 в 8-разрядной ячейке памяти компьютера Ниже запишите ответ - только само число, без пояснений 2) Запишите внутреннее представление десятичного числа 79 в 8-разрядной ячейке памяти
Ответы (1)
Дано трехзначное число. Напишите программу, которая определяет: является ли число "перевертышем", т. е. числом, десятичная запись которого читается одинаково слева направо и справа налево. 122 - нет 121 - перевертыш 222 - перевертыш
Ответы (1)
1. Дано натуральное число. Верно ли, что сумма его цифр есть четное число, а само число не превышает b? 2. Дано натуральное число. Верно ли, что сумма его цифр больше m а само число делится на n?
Ответы (1)
1. Дано двузначное число. Определить: a. какая из его цифр больше, первая или вторая; b. одинаковы ли его цифры. 2. Дано двухзначное число. Определить, равен ли квадрат этого числа учетверённой сумме кубов его цифр.
Ответы (1)
Дано трехзначное число. вывести последовательно на экран сумму его цифр, произведение его цифр "число перевертыш"
Ответы (1)