Задать вопрос
10 августа, 20:14

Построить машину тьюринга которая во входном слове все буквы И меняет на Е

+5
Ответы (1)
  1. 10 августа, 20:42
    0
    Var a: string;

    i: integer;

    begin

    readln (a) ;

    for i : = 0 to length (a) do

    if (a[i] = 'и') then a[i] : = 'е';

    writeln (a) ;

    end.

    Это на Pascal'е =)
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Построить машину тьюринга которая во входном слове все буквы И меняет на Е ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Машина Тьюринга. Перенести первый символ в конец слова. A={a, b, c}. Пусть P - не пустое конечное слово более чем из 1-ого символа. Необходимо составить программу, которая перенесет первый символ слова в его конец.
Ответы (1)
Машина Тьюринга. Как будет выглядеть программа умножения на 2
Ответы (1)
По горизонтали: 1. Объект Windows (4, буквы) 2. А4 - это ... (6, буквы) 3. Есть у человека и компьютера. (6, буквы) 4. Начни работу с этой кнопки ... (4, буквы) 5. Чтобы работать с объектом, его надо ... (8, буквы) 6. Есть в ресторане и компьютере.
Ответы (1)
Дмитрий отправляется в школу, которая находится в 1 км от его дома. Дойдя до школы, он вдруг вспоминает, что забыл дома тетради, и поворачивает назад. Пройдя полпути, он меняет своё решение, посчитав что лучше вернуться в школу до звонка на урок.
Ответы (1)
Дан список слов кран склон кратер кража 1 в слове не пять букв 2 в слове две гласных и четыри буквы согласных 3 в слове две гласных или четыри буквы согласных 4 в слове четыри буквы и не две буквы согласных
Ответы (1)