Задать вопрос
26 ноября, 01:58

дан массив найти произведение отрицательных элементов и кратных 7

+2
Ответы (1)
  1. 26 ноября, 03:44
    0
    Program Massiv;

    Uses Crt;

    const n=10 {размер массива}

    var i, k:integer;

    a:array[1 ... n] of integer;

    begin

    clrscr;

    write ('Введите элементы массива:') ;

    k:=1

    for i:=1 to n do

    begin

    readln (a[i]) ;

    if (a[i]<0) and (a[i] mod 7) = 0 then k:=k*a[i];

    end;

    writeln;

    write ('Исходный массив:')

    for i:=1 to n do write (a[i]:3) ;

    writeln;

    writeln ('Произведение отрицательных элементов кратных 7:', k) ;

    readkey;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «дан массив найти произведение отрицательных элементов и кратных 7 ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Хотя бы 3-4 задачи! 1) Дан одномерный целочисленный массив размерностью N. Найдите количество элементов, которые кратны 3 (5). 2) Дан одномерный целочисленный массив А, состоящий из N элементов. Найти сумму всех четных элементов массива.
Ответы (1)
Помогите решить задачи на паскаль. 1) Дан массив случайных чисел (количество элементов вводите с клавиатуры). Найти произведение всех элементов массива. 2) Дан массив случайных чисел (количество элементов вводите с клавиатуры).
Ответы (1)
1) Дан массив из n элементов. Найти номер наименьшего элемента массива. 2) Дан массив из n элементов. Упорядочить массив по возрастанию. 3) Дан массив из n элементов. Упорядочить массив по убыванию.
Ответы (1)
1) Дан одномерный массив А[N], - целых чисел. Заменить все большие 7 члены массива числом 7. Найти количество таких членов. 2) Задан массив из 10 элементов, найти произведение элементов массива. Задача №3.
Ответы (1)
дан массив из семи элементов написать программу подсчитывающую среднее второго и предпоследнего элементов массива дан целочисленный массив из 10 элементов написать программу находящую сумму элементов массива красных 3 ил 5 дан целочисленный массив
Ответы (1)