Задать вопрос
3 февраля, 15:35

Найти все двузначные числа, квадрат суммы цифр которых делится на 15 (4 способа)

+4
Ответы (1)
  1. 3 февраля, 19:24
    0
    program z;

    var i, a, a1, s:integer;

    begin

    writeln ('Двухзначные числа, квадрат суммы цифр которых делится 13') ;

    for i:=10 to 99 do

    begin

    a:=i;

    s:=0;

    while a0 do

    begin

    a1:=a mod 10;

    s:=s+a1;

    a1:=a div 10;

    a:=a1;

    end;

    if sqr (s) mod 13=0

    then

    writeln (i) ;

    end;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Найти все двузначные числа, квадрат суммы цифр которых делится на 15 (4 способа) ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
1. Дана цифра А. Найти все двузначные числа в которых встречается эта цифра. 2. Вывести на экран все двузначные числа сумма цифр которых делится на 5. 3. Найти среднее арифметическое чисел в промежутке от А до В.
Ответы (1)
Дано натуральное число: определить а) количество цифр в нем б) сумму его цифр в) произведение его цифр г) среднее арифметическое его цифр д) сумму квадратов его цифр е) сумму кубов его цифр ж) его первую цифру з) сумму его первой и последней цифр
Ответы (1)
1) Найти минимальное число, большее 300, которое нацело делится на 19.2) С клавиатуры вводится натуральное число n. Найти количество цифр этого числа, их сумму, количество четных и нечетных цифр, сколько цифр в числе делится на 3.
Ответы (1)
Решить задачи • Найдите сумму цифр числа; • Найдите первую цифру числа; • Поменяйте порядок цифр числа на обратный; • Найдите количество четных цифр числа; • Найдите наибольшую цифру числа; • Найдите сумму цифр числа, больших 5.
Ответы (1)
Составить программу в Pascal: Найти все трехзначные числа, обладающие следующими свойствами: - сумма цифр числа А делится на 4; - сумма цифр числа А+2 также делится на 4
Ответы (1)