Задать вопрос
7 августа, 20:32

Решать массивом. Найти сумму элементов, принадлежащих промежутку от А до В (А и В вводить с клавиатуры). составить программу

+4
Ответы (1)
  1. 8 августа, 00:23
    0
    Program n1;

    Uses CRT;

    Const n=20;

    Var m: array[1 ... n] of integer;

    i, a, s, b: integer;

    begin

    ClrScr;

    Randomize;

    For i:=1 to n do

    begin

    m[i]:=random (50) ;

    write (m[i]:3) ;

    end;

    writeln;

    writeln ('Введите A и B') ;

    readln (a, b) ;

    For i:=a to b do

    s:=s+m[i];

    writeln ('Сумма равна ', s) ;

    readln

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Решать массивом. Найти сумму элементов, принадлежащих промежутку от А до В (А и В вводить с клавиатуры). составить программу ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Помогите решить задачи на паскаль. 1) Дан массив случайных чисел (количество элементов вводите с клавиатуры). Найти произведение всех элементов массива. 2) Дан массив случайных чисел (количество элементов вводите с клавиатуры).
Ответы (1)
1. Найти сумму элементов массива принадлежащих промежутку от C до D (C и D вводятся с клавиатуры). 2. Определить есть ли в данном массиве положительные элементы кратные k (k вводится с клавиатуры). Паскаль
Ответы (1)
1. Написать программу, вычисляющую сумму отрицательных чисел, кратных 5, среди пяти, вводимых с клавиатуры. 2. Написать программу, вычисляющую произведение чисел, оканчивающихся цифрами 2 и 4, среди пяти, вводимых с клавиатуры. 3.
Ответы (1)
Решить не могу задачи по информатике: 1. Составьте программу ввода элементов массива h [1 ... 8] с клавиатуры и вывода на экран элементов с отрицательными значениями. 2. Составьте программу, которая заполняет массив h [1 ...
Ответы (1)
Решите задачи: 1) Составьте программу ввода элементов массива [1 ... 8] с клавиатуры и вывода на экран элементов массива с отрицательными значениями. 2) Составьте программу, которая заполняет массив а [1 ...
Ответы (1)