Задать вопрос
27 апреля, 19:09

1. Найти сумму элементов массива принадлежащих промежутку от C до D (C и D вводятся с клавиатуры). 2. Определить есть ли в данном массиве положительные элементы кратные k (k вводится с клавиатуры). Паскаль

+4
Ответы (1)
  1. 27 апреля, 19:18
    0
    const

    N = 12;

    var

    a: array[1 ... N] of integer;

    c, d, k, count, sum, i: integer;

    begin

    writeln ('Введите промежуток: ') ; readln (c, d) ;

    writeln ('Введите k: ') ; readln (k) ;

    for i : = 1 to N do begin

    a[i] : = random (30) ;

    write (a[i], ' ') ;

    if (a[i] > 0) and (a[i] mod k = 0) then inc (count) ;

    end;

    for i : = c to d do begin

    sum : = sum + a[i];

    end;

    writeln;

    writeln ('Сумма элементов на промежутке [', c,'; ', d,'] : ', sum) ;

    if (count 0) then writeln ('Положительных элементов кратных ', k, ' : ', count) ;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «1. Найти сумму элементов массива принадлежащих промежутку от C до D (C и D вводятся с клавиатуры). 2. Определить есть ли в данном массиве ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
1. Возвести в квадрат все элементы массива A. Размер массива и значения элементов массива - произвольные. 2. Увеличить на 4 все элементы в первой половине массива A (считать, что в массиве чётное число элементов).
Ответы (1)
Все задачи делаются в Паскале! 1) Увеличить все элементы массива A на 1. 2) Умножить все элементы массива A на 2. 3) Возвести в квадрат все элементы массива A.
Ответы (1)
1. Массив и 4 целых чисел вводится с клавиатуры. Найти и вывести произведение элементов массива. 2. Массив из 6 отрицательных и положительных целых чисел вводится в области описания констант. Найти сумму положительных элементов массива. 3.
Ответы (1)
Составить программу на языке Паскаль: 1) Для массива K из 12 вещественных чисел определить сколько элементов массива меньше 0. 2) В массиве М из 10 целых чисел найти количество элементов равных 3.
Ответы (1)
Создать два одномерных массива, состоящих из целых чисел. Элементы массива вводятся с клавиатуры. В первом массиве найти номер первого нечетного элемента массива. Во втором массиве найти первый четный элемент массива.
Ответы (1)