Задать вопрос
11 февраля, 11:55

из чисел от 100 до 999 вывести те, сумма цифр которых числу N, введенному с клавиатуры.

+1
Ответы (1)
  1. 11 февраля, 14:01
    0
    Program n1;

    Uses CRT;

    Var a, b, c, k, n, i: integer;

    begin

    ClrScr;

    writeln ('vvedite n') ;

    readln (n) ;

    For i:=100 to 999 do

    begin

    a:=i div 100;

    b:=i mod 100 div 10;

    c:=i mod 10;

    If a+b+c=n then

    begin

    write (i:4) ;

    k:=k+1;

    end;

    end;

    if k=0 then writeln ('takih chisel net') ;

    readln

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «из чисел от 100 до 999 вывести те, сумма цифр которых числу N, введенному с клавиатуры. ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
1. Прочитать с клавиатуры число n, затем прочитать n чисел и вывести на экран сумму тех из них, которые делятся на 3. 2. Прочитать с клавиатуры число n и вывести на экран сумму его четных цифр 3.
Ответы (1)
1. for + random a. вывести случайное количество случайных чисел b. вывести на экран 10 случайных чисел c. вывести на экран 10 случайных чисел, значение которых лежит в отрезке [0,10] d.
Ответы (1)
Напишите программу, которая принимает с клавиатуры числа, пока не будет введено значение 999. Программа должна подсчитать, сколько значений было введено с клавиатуры (не считая значения 999) и вывести эту информацию на экран.
Ответы (1)
Информатика 8 класс 1) вывести трехзначные числа сумма цифр которых простое число 2) Определить сумму цифр трехзначного числа 3) определить являеться ли четным число введенное с клавиатуры 4) определить НОК (наименьшее обшее кратноечисло без
Ответы (1)
Паскаль. 1. вывести на экран все четные числа от 1 до n. 2. вывести на экран все трехзначные числа. 3. вывести на экран четырехзначные числа оканчивающийся на 7. 4. вывести на экран все трехзначные и двухзначные числа сумма цифр которых равна девяти.
Ответы (1)