Задать вопрос
20 декабря, 17:39

найти сумму всех четырехзначных чисел в записи которых встречается хотя бы одна цифра 5

+1
Ответы (1)
  1. 20 декабря, 20:39
    0
    Program n1;

    Uses CRT;

    Var a, b, c, d, s, i: integer;

    begin

    For i:=1000 to 9999 do

    begin

    a:=i div 1000;

    b:=i mod 1000 div 100;

    c:=i mod 100 div 10;

    d:=i mod 10;

    If (a=5) or (b=5) or (c=5) or (d=5) then s:=s+i;

    end;

    writeln ('summa ravna ', s) ;

    readln

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «найти сумму всех четырехзначных чисел в записи которых встречается хотя бы одна цифра 5 ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Придумайте натуральное число которое удовлетворяет следущим условиям: 1. Запись числа состоит из 7 цифр 2. Сумма всех цифр числа равна 39. 3. В записи числа есть хотя бы одна цифра 4 4. В записи числа есть хотя бы одна цифра 7 5.
Ответы (1)
1. Дана цифра А. Найти все двузначные числа в которых встречается эта цифра. 2. Вывести на экран все двузначные числа сумма цифр которых делится на 5. 3. Найти среднее арифметическое чисел в промежутке от А до В.
Ответы (1)
1. Даны два целых числа A и B (A < B). Найти сумму всех чисел от A до B включительно. 2. Даны два целых числа A и B (A 0). Найти произведение всех чисел от A до B включительно. 3. Дан массив целых чисел Х. Найти сумму квадратов всех чисел. 4.
Ответы (1)
1) Напишите программу, которая в последовательности натуральных чисел определяет сумму четырехзначных чисел, кратных 6.
Ответы (1)
Найти: а) сумму всех целых чисел от 100 до 500; б) сумму всех целых чисел от a до 500 (значение a вводится с клавиатуры; a 500) ; в) сумму всех целых чисел от - 10 до b (значение b вводится с клавиатуры; b - 10) ;
Ответы (1)