Задать вопрос
19 августа, 09:39

Упорядочите элементы массива А в порядке убывания

В Pascal ABC

+2
Ответы (1)
  1. 19 августа, 12:58
    0
    uses crt;

    var a:array [1 ... 100]of integer;

    n, i, j, k, x:integer;

    begin

    clrscr;

    randomize;

    write ('n=') ; readln (n) ;

    writeln ('Ishodnyj massiv:') ;

    for i:=1 to n do

    begin

    a[i]:=random (200) ;;

    write (a[i],' ') ;

    end;

    writeln;

    for i:=2 to n do

    begin

    x:=a[i];

    j:=1;

    while x>a[j] do inc (j) ;

    for k:=i-1 downto j do a[k+1]: = a[k];

    a[j]:=x;

    end;

    writeln ('Otsortirovannyj massiv:') ;

    for i:=1 to n do

    write (a[i],' ') ;

    readln

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Упорядочите элементы массива А в порядке убывания В Pascal ABC ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
1. Возвести в квадрат все элементы массива A. Размер массива и значения элементов массива - произвольные. 2. Увеличить на 4 все элементы в первой половине массива A (считать, что в массиве чётное число элементов).
Ответы (1)
Все задачи делаются в Паскале! 1) Увеличить все элементы массива A на 1. 2) Умножить все элементы массива A на 2. 3) Возвести в квадрат все элементы массива A.
Ответы (1)
В записи m[7]=9 m обозначает 1) имя массива 2) имя элемента массива 3) номер элемента массива 4) значение элемента массива в записи m[7]=
Ответы (1)
Pascal ABC Напишите программу, которая находит три наименьших элемента массива и переставляет их в начало массива. Остальные элементы должны следовать далее в том же порядке. Входные данные Первая строка содержит размер массива N.
Ответы (1)
Помогите с информатикой 1. Что такое массив? 2. Что такое элемент массива? 3. Что такое индекс массива? 4. Что такое размерность массива? 5. Зачем нужны массивы? 6. Как можно обратиться к ячейке массива? 7. Какого типа могут быль элементы массива? 8.
Ответы (1)