Задать вопрос
22 марта, 09:11

Имеется трёхзначное число, цифры которого различны. После зачёркивания в нём последней цифры, остаётся двузначное число, являющееся делителем данного. Найдите N-первых таких трёхзначных чисел. (N=70)

+4
Ответы (1)
  1. 22 марта, 12:13
    0
    Var k, x, a:integer;

    Begin

    x:=100;

    k:=0;

    repeat

    a:=x div 10;

    if (x mod a) = 0 then

    begin

    writeln (x) ;

    k:=k+1;

    end;

    x:=x+1;

    until k=70;

    End.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Имеется трёхзначное число, цифры которого различны. После зачёркивания в нём последней цифры, остаётся двузначное число, являющееся ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Введите трёхзначное число. Определите, все ли цифры данного числа различны и выведите на экран соответствующее сообщение: "Различны" либо "Одинаковые".
Ответы (1)
Программирование в python 3 Напечатать массив и сумму его первых N десятков. Пример: Пользователь вводит любое число, например 56 Программа выдаёт на экран массив от 0 до 55 и ещё пять чисел: сумму первых 10, сумму первых 20, сумму первых 30, сумму
Ответы (1)
1) Напишите программу которая в последствии натуральных чисел определяет, находит сумму двузначных чисел не кратных 4. В последовательности обязательно имеется двузначное число не кратное 4.
Ответы (1)
1. Среди трехзначных чисел сколько таких, что сумма крайних в три раза больше средней цифры. 2. Среди трехзначных чисел сколько таких, что все цифры разные
Ответы (1)
Паскаль. 1) Дано трехзначное число, нужно найти число, полученное при прочтении его цифр справа налево. 2) Дано трехзначное число. В нем зачеркнули последнюю справа цифру и приписали ее в начале. Найти полученное число. 3) Дано трехзначное число.
Ответы (1)