Задать вопрос
21 сентября, 07:50

Может кто нибудь написать небольшую программу по паскалю с массивами. И описать что выполняет каждая команда? Нужно на олимпиаде хоть что нибудь написать.

+3
Ответы (1)
  1. 21 сентября, 09:31
    0
    задание одномерного массива:

    varИмяМассива:array [НижняяГраница ... ВерхняяГраница] ofТипЭлементов;

    задание двумерного массива:

    varИмяМассива:array [НижняяГраница1 ... ВерхняяГраница1, НижняяГраница2 ... ВерхняяГраница2] ofТипЭлементов;

    заполение массива:

    одномерный массив: for i:=1 to5do readln (a[i]) ; {ввод с клавиатуры}

    двумерный массив: for i:=1 to3do

    for j:=1 to2do readln (a[i, j]) ;

    вывод массива на экран:

    в столбец:for i:=1 to5do writeln (a[i]) ;

    в строку:for i:=1 to5do write (a[i],' ') ;

    матрица двумерного массива:

    for i:=1 to n do

    begin

    for j:=1 to m do

    write (a[i, j]:4) ;

    writeln;

    end;

    действия с одномерным массивом:

    вычисление суммы элементов:

    s:=0;

    for i:=1 to n do s:=s+a[i];

    подсчет элементов, удовлетворяющих условию:

    k:=0;

    for i:=1 tondo

    if a[i] УсловиеОтбора then k:=k+1;
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Может кто нибудь написать небольшую программу по паскалю с массивами. И описать что выполняет каждая команда? Нужно на олимпиаде хоть что ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Прошу, помогите написать программу! (Тема - Операции над массивами.) Написать программу, которая в одномерном массиве, заданным вводом данных с клавиатуры находит число положительных чисел в массиве.
Ответы (1)
Как перевести 7 в 8 за 4 шага. 1 ая команда + 5; 2 ая команда: 2; И ещё Как перевести 4 в 55 за 5 шагов. 1 ая команда * 5; 2 ая команда - 3;
Ответы (1)
Надо составить программу по паскалю) составить программу проверяющую утверждения, что сумма цифр введенного вами числа делится на 5.
Ответы (1)
В розыгрыше первенства по волейболу команда А отстала от команды Б на три места, команда Е опередила Б, но отстала от Д, команда В опередила команду Г. Какое место заняла каждая из шести команд?
Ответы (1)
Вычислить произведение четырех натур. чисел, используя только операцию сложения. (Язык пр:pascal) 1) Написать программу (обычную) 2) Написать программу с использованием процедуры 3) Написать программу с исп. функции 4) Написать программу с исп.
Ответы (1)