Задать вопрос
21 ноября, 01:50

Найти в массиве элемент равный Х или установить что он отсутствует. Программа на Паскале

+1
Ответы (1)
  1. 21 ноября, 03:06
    0
    Если нужны объяснения то пиши в личку)

    Program zada4a;

    var

    i, x, n: integer;

    a: array [1 ... 100] of integer;

    begin

    n:=0;

    write ('Введите x - ') ;

    readln (x) ;

    for i:=1 to 5 do - если попросят чтобы выводилось больше 5 чисел, то поменяйте цифру 5 на нужную.

    begin

    a[i]:=random (21) ; - это строчка озночает, что задаются числа интервалом от 0 до 20.

    write (a[i]:5) ;

    end;

    writeln;

    for i:=1 to 5 do

    begin

    if x=a[i] then

    begin

    writeln ('Элемент в массиве равный ', x,' находится под номером - ', i) ;

    n:=n+1;

    end;

    end;

    if n=0 then

    write ('Элемент c таким значением отсутствоет') ;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Найти в массиве элемент равный Х или установить что он отсутствует. Программа на Паскале ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Массив a[1 ... 10] заполните случайными целыми числами в диапазоне от 1 до 10. Определите, есть ли в массиве элемент, равный 5. Ответ выведите в виде слов "Да" или "Нет".
Ответы (1)
Напишите программу, которая находит в массиве максимальный повторяющийся элемент или выводит число - 1, если ни один элемент не повторяется. Входные данные Первая строка содержит размер массива N.
Ответы (1)
Помогите сделать программу в Паскале В котором 1) Программа выдает сообщение "Вы маль или дево" 2) Пользователь в переменную ST1 задает значение маль или дево 3) Программа выдает сооб "Ты пошла бы играть в куклы" 4) Вводить ответ через переменную
Ответы (1)
Сгенерировать массив из N случайных целых чисел и вывести его. Ввести целое число. Определить, есть ли в массиве элемент, равный этому числу, или вывести сообщение, что нет такого значения в массиве
Ответы (1)
Даны системы счисления: 2-ая, 8-ая, 10-ая, 16-ая. Запись вида 100 отсутствует в десятичной системе счисления существует во всех названных системах счисления отсутствует в восьмеричной отсутствует в шестнадцатеричной отсутствует в двоичной
Ответы (2)