Задать вопрос
25 мая, 02:42

Помогите решить задачи в паскале. 1) Подсчитать количество предложений в заданном тексте. 2) Найти сумму цифр в целой и в дробной части числа, введенного в виде текстовой строки.

+3
Ответы (1)
  1. 25 мая, 05:24
    0
    1) тк не уточнила загружаем из файла, или вводим с клавиатуры, получай с этими двумя функциями. в каталоге с программой должен быть файлик. txt

    var a, filename:string[255];

    chk, i, res:integer;

    f1:Text;

    begin

    res:=0;

    chk:=0;

    Writeln ('1. Input line') ;

    Writeln ('2. Load from file') ;

    Readln (chk) ;

    if chk=1 then

    begin

    Writeln ('Input line: ') ;

    Readln (a) ;

    for i:=1 to Length (a) do

    if a[i]='.' then

    res:=res+1;

    Writeln ('Result: ', res) ;

    end;

    if chk=2 then

    begin

    writeln ('Input name of file: ') ;

    Readln (filename) ;

    filename:=filename+'. txt';

    Assign (f1, filename) ;

    Reset (f1) ;

    while not eof (f1) do

    begin

    readln (f1, a) ;

    writeln (a) ;

    for i:=1 to Length (a) do

    if a[i]='.' then

    res:=res+1;

    end;

    Writeln ('Result: ', res) ;

    Close (f1) ;

    end;

    readln;

    end.

    2) вводим не запятую, а точку, как разделитель частей числа

    var a, substr:string[100];

    x, res, i:integer;

    begin

    writeln ('Input number:') ;

    Readln (a) ;

    substr:='.';

    x:=Pos (substr, a) ;

    for i:=1 to x-1 do

    res:=res+strtoint (a[i]) ;

    Writeln ('Result of first part: ', res) ;

    res:=0;

    for i:=x+1 to Length (a) do

    res:=res+StrToInt (a[i]) ;

    Writeln ('Result of second part: ', res) ;

    readln;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Помогите решить задачи в паскале. 1) Подсчитать количество предложений в заданном тексте. 2) Найти сумму цифр в целой и в дробной части ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Дано натуральное число: определить а) количество цифр в нем б) сумму его цифр в) произведение его цифр г) среднее арифметическое его цифр д) сумму квадратов его цифр е) сумму кубов его цифр ж) его первую цифру з) сумму его первой и последней цифр
Ответы (1)
1. Напечатайте индексы всех равных элементов произвольного массива A (N; N). 2. В заданном тексте заменить последовательность символов X (I) на A (I), подсчитать количество произведенных замен. эти две задачи необходимо решить в турбо паскале
Ответы (1)
Решить задачи • Найдите сумму цифр числа; • Найдите первую цифру числа; • Поменяйте порядок цифр числа на обратный; • Найдите количество четных цифр числа; • Найдите наибольшую цифру числа; • Найдите сумму цифр числа, больших 5.
Ответы (1)
1. Составьте программу, которая определяет, является ли сумма цифр введенного целого трехзначного числа четным числом. 2. Составьте программу, которая определяет, является ли последняя цифра введенного целого числа нечетным числом. 8 класс.
Ответы (1)
Написать программу в Паскале. Подсчитать сумму четных целых чисел находящихся от одного до значения введенного пользователем
Ответы (1)