Задать вопрос
19 июня, 12:39

Мальчик, продающий на улице газеты, зарабатывает А руб. на продаже каждой из первых 75 газет. На каждой из остальных проданных газет он зарабатывает по Х руб. Напишите программу, которая выведет заработок мальчика, если он продаст B газет.

+4
Ответы (1)
  1. 19 июня, 13:28
    0
    Var

    A, B, X : Integer;

    begin

    Writeln ('Введите кол-во газет:') ; / / Просим пользователя ввести кол-во газет

    Readln (B) ; / / Считываем то, что он ввел

    Writeln ('Введите цену первых 75 газет:') ;

    Readln (A) ;

    Writeln ('Введите цену остальных газет:') ;

    Readln (X) ;

    if B < = 75 then / / Условие: если газет 75 или меньше, то ...

    Writeln ('Мальчик заработает ', B * A, 'рублей.')

    else / / Иначе ...

    Writeln ('Мальчик заработает ', 75 * A + (B - 75) * X, 'рублей.') ;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Мальчик, продающий на улице газеты, зарабатывает А руб. на продаже каждой из первых 75 газет. На каждой из остальных проданных газет он ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Уличный продавец газет получает а рублей с продажи каждой из первых 50 газет. С продажи каждой из остальных газет он получает на 20% больше. Разработайте программу, которая вычислит заработок продавца, если он продаст за день 200 газет.
Ответы (1)
уличный продавец газет получает a рублей с продажи каждой из первых 50 газет. С продаж каждой из остальных газет он получает на 20% больше. разработайте программу, которая вычислит заработок продавца, если он продает за день 200 газет.
Ответы (1)
4. В городской библиотеке на компьютере в каталоге Периодика хранился файл Газеты. xls. Этот файл переместили в каталог, в котором непосредственно расположен файл с полным именем Р:/Газеты/Архив/Газеты. с1 ос.
Ответы (1)
Помогите написать программу в Python. 1) Дан массив, состоящий из целых чисел. Нумерация элементов начинается с 0. Напишите программу, которая выведет элементы массива, номера которых четны (0, 2, 4 ...). 2) Дан массив, состоящий из целых чисел.
Ответы (1)
В продаже имеются следующие компьютерные устройства: Клавиатура 1200 руб. Джойстик 2100 руб. Сканер 2500 руб. Системный блок 25000 руб. Мышь 990 руб. Акустические колонки 2600 руб. Принтер 4500 руб. Монитор 4500 руб.
Ответы (1)