Задать вопрос
11 февраля, 02:11

Составьте программу вычисления площади кольца с внутренним радиусом R1 и внешним радиусом R2. Значения R1 и R2 введите с клавиатуры

+1
Ответы (1)
  1. 11 февраля, 02:37
    0
    Если твое кольцо есть фигура Тор, то это внешний и внутренний радиусы. (Внешний больше). Тогда код вот такой:

    uses crt;

    var

    r1, r2: real;

    begin

    read (r1, r2) ;

    writeln (pi * (r1*r1-r2*r2) : 0:3) ;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Составьте программу вычисления площади кольца с внутренним радиусом R1 и внешним радиусом R2. Значения R1 и R2 введите с клавиатуры ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
1. Напишите программу вычисления расстояния между двумя точками плоскости. 2. Напишите программу вычисления площади боковой поверхности куба. 3. Напишите программу вычисления площади и гипотенузы прямого треугольника, если известны его катеты. 4.
Ответы (1)
1. Составьте программу вычисления значение функций у по формуле у=х cos x + sin x, для которой значение аргумента х введите с клавиатуры Отладьте программу на следующем примере: х=5 у=0,459387 2.
Ответы (1)
Напишите программу вычисления площади кольца, радиусы вводятся с клавиатуры. Используйте функцию вычисления площади круга
Ответы (1)
Составте программу, вычисления суммы цифр трёхзначного числа а. Значение а введите с клавиатуры Пример ввода: 375 Пример вывода: Сумма цифр числа 375 равна 15 2) Составте программу, которая получает 'перевёртыш' трёхзначного числа а.
Ответы (1)
1) Составьте программу вычисления сумму чисел от 1 до 100. 2) Составьте программу вычисления произведения чётных чисел от 1 до 10. 3) Составьте программу вычисления количества двухзначных нечётных чисел.
Ответы (1)