Задать вопрос
25 апреля, 09:12

Напишите программу вычисления площади кольца, радиусы вводятся с клавиатуры. Используйте функцию вычисления площади круга

+1
Ответы (1)
  1. 25 апреля, 11:53
    0
    Var r1, r2, s:real;

    function square (r:real) : real;

    begin

    square:=pi*r*r;

    end;

    begin

    writeln ('r1, r2:') ;

    readln (r1, r2) ;

    s:=abs (square (r1) - square (r2)) ;

    writeln ('Площадь кольца = ', s:5:2) ;

    end.

    Пример:

    r1, r2:

    3 5

    Площадь кольца = 50.27
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Напишите программу вычисления площади кольца, радиусы вводятся с клавиатуры. Используйте функцию вычисления площади круга ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
1. Напишите программу вычисления корней квадратного уравнения, если с клавиатуры, если коэффициенты вводятся с клавиатуры (a, b, c) 2. Координаты 2-х точек плоскости вводятся с клавиатуры.
Ответы (1)
1) с клавиатуры вводятся количество целых чисел и сами числа. найти среднее арифметическое квадратов введенных чисел 2) с клавиатуры вводятся натуральные числа a и n. Написать программу вычисления a в степени n.
Ответы (1)
1. Напишите программу вычисления расстояния между двумя точками плоскости. 2. Напишите программу вычисления площади боковой поверхности куба. 3. Напишите программу вычисления площади и гипотенузы прямого треугольника, если известны его катеты. 4.
Ответы (1)
Помогите решить задачи! 1. Дан массив размера 10, числовые значения которого вводятся с клавиатуры. Вывести максимальный элемент данного массива и его номер. 2. Дан массив размера 10, числовые значения которого вводятся с клавиатуры.
Ответы (1)
1) C клавиатуры вводятся 10 чисел. Найти сумму тех из них, которые больше 10. 2) Найти произведение двузначных нечетных чисел. 3) С клавиатуры вводятся N чисел.
Ответы (1)