Задать вопрос
8 марта, 01:11

помогите решить задачу:

дан двумерный массив. найти среднее арифметическое четных элементов массива. (Gambas) !

+1
Ответы (1)
  1. 8 марта, 03:33
    0
    Pascal

    const N = 10;

    var arr: array[1 ... N] of integer;

    i, k: byte;

    sum: integer;

    avr: real;

    begin

    writeln ('Enter the ten elements of the array:') ;

    for i:=1 to N do

    read (arr[i]) ;

    sum : = 0;

    i : = 1;

    k : = 0;

    while i < = N do begin

    if (arr[i] mod 2) = 0 then begin

    sum : = sum + arr[i];

    k : = k + 1

    end;

    i : = i + 2

    end;

    writeln (sum) ;

    if k 0 then begin

    avr : = sum / k;

    writeln (avr)

    end

    else

    writeln ('No elements') ;

    readln;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «помогите решить задачу: дан двумерный массив. найти среднее арифметическое четных элементов массива. (Gambas) ! ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Хотя бы 3-4 задачи! 1) Дан одномерный целочисленный массив размерностью N. Найдите количество элементов, которые кратны 3 (5). 2) Дан одномерный целочисленный массив А, состоящий из N элементов. Найти сумму всех четных элементов массива.
Ответы (1)
дан массив из семи элементов написать программу подсчитывающую среднее второго и предпоследнего элементов массива дан целочисленный массив из 10 элементов написать программу находящую сумму элементов массива красных 3 ил 5 дан целочисленный массив
Ответы (1)
Помогите решить задачи на паскаль. 1) Дан массив случайных чисел (количество элементов вводите с клавиатуры). Найти произведение всех элементов массива. 2) Дан массив случайных чисел (количество элементов вводите с клавиатуры).
Ответы (1)
1) Дан одномерный массив А[N], - целых чисел. Заменить все большие 7 члены массива числом 7. Найти количество таких членов. 2) Задан массив из 10 элементов, найти произведение элементов массива. Задача №3.
Ответы (1)
1. Дан двумерный массив размером 3x5. Вычислить сумму элементов массива 2. Дан массив целых чисел размеров 4 х4. Заменить все элементы главной диагонали на нули. Вывести на экран монитора содержимое массива до обработки и после обработки 3.
Ответы (1)