Задать вопрос
12 апреля, 08:01

Составьте программу определяющую, является ли число x простым

+2
Ответы (1)
  1. 12 апреля, 09:40
    0
    Uses crt; var a : real; p : boolean; i : integer; procedure haltproc; begin writeln ('неверные данные') ; writeln ('a>=2') ; readln; halt; end; begin clrscr; write ('a=') ; readln (a) ; if a<2 then haltproc; if a=2 then begin writeln2 ('простое') ; readln; halt; end; p:=true; for i:=2 to trunc (a-1) do if a/i=trunc (a/i) then p:=false; if p=true then write ('простое') else write ('не простое') ; readln; end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Составьте программу определяющую, является ли число x простым ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Информатика "Программирование разветвляющихся алгоритмов" 1. Написать программу, определяющую, является ли произвольное число X четным. 2. Написать программу, определяющую, является ли целое число T делителем целого числа X. 3.
Ответы (1)
Помогите информатика 8 класс Задача 1. Составить программу определяющую длину фамилии и имени. Задача 2. Даны два слова. Составить программу определяющую произведение данных слов. Задача 3.
Ответы (1)
Задание 1. составьте программу, определяющую, является ли число х простым. число х введите с клавиатуры. число называется простым, если у него нет других делителей, кроме 1 и его самого.
Ответы (1)
Составить программу, определяющую, является ли данное утверждение истинным: Двузначное число А начинается на 3 Составить программу, определяющую, является ли данное утверждение истинным: Ровно одно из чисел А и В не превышает 100
Ответы (1)
1. Напишите программу, определяющую сумму S=1+2+3+4 ... + 99 2. Напишите программу, определяющую произведение P=1*2*3*4 ... * 10 На Паскаль За ранее благодарна
Ответы (1)