Задать вопрос
16 декабря, 00:01

Введите с клавиатуры целое число в диапазоне 1-999.

а) Определите количество знаков в числе;

б) Определите четность числа;

в) Выведите описание числа, например,"нечетное однозначное число","четное двухзначное число" и тд.

Пример ввода: 347

Пример вывода: Нечетное трехзначное число

+5
Ответы (1)
  1. 16 декабря, 00:28
    0
    Type num=1 ... 999;

    Var x:num; k, y:integer;

    Begin

    write ('x=') ;

    readln (x) ;

    y:=x;

    k:=0;

    while y0 do

    begin

    y:=y div 10;

    k:=k+1;

    end;

    if (x mod 2) = 0 then

    write ('Четное ')

    else

    write ('Нечетное ') ;

    if k=1 then write ('однозначное ')

    else

    if k=2 then write ('двухзначное ')

    else

    write ('трехзначное ') ;

    writeln ('число') ;

    End.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Введите с клавиатуры целое число в диапазоне 1-999. а) Определите количество знаков в числе; б) Определите четность числа; в) Выведите ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Составте программу, вычисления суммы цифр трёхзначного числа а. Значение а введите с клавиатуры Пример ввода: 375 Пример вывода: Сумма цифр числа 375 равна 15 2) Составте программу, которая получает 'перевёртыш' трёхзначного числа а.
Ответы (1)
1. Переключение клавиатуры с режима ввода латинских букв на режим ввода русских букв и обратно? 2. переключение клавиатуры с режима ввода строчных букв на режим ввода прописных букв и обратно? 3.
Ответы (1)
1. Верное высказывание: а) Принтер - устройство ввода/вывода б) CD - ROM - устройство вывода в) Компакт-диск - устройство для хранения информации г) Клавиатура устройство ввода/вывода д) Монитор - устройство ввода
Ответы (1)
Составьте программу ввода с клавиатуры элементов массива a[1 ... 8] и вывода элементов массива в обратном порядке (пример ввода: 1 2 3 4 5 6 7 8 пример вывода 8 7 5 4 3 2 1
Ответы (1)
Задание 1: Составьте программу ввода с клавиатуры массива целых чисел a[1 ... 10] и вывода на экран элементов массива с нечетными значениями. Задание 2:Составьте программу ввода с клавиатуры массива целых чисел a[1 ...
Ответы (1)