Задать вопрос
11 октября, 18:26

8. Дан двумерный массив. Определить: А) сумму всех элементов массива; Б) сумму квадратов всех элементов массива.

+2
Ответы (1)
  1. 11 октября, 20:09
    0
    Program Pr1;

    uses crt;

    const n=20;

    var mas:array[1 ... n, 1 ... n] of integer;

    i, j, v:integer;

    Begin

    clrscr;

    v:=0;

    randomize;

    for j:=1 to n do

    for i:=1 to n do mas[i, j]:=random (10) ;

    for j:=1 to n do

    for i:=1 to n do v:=v+mas[i, j];

    writeln ('Summa=', v) ; {a}

    v:=0;

    for j:=1 to n do

    for i:=1 to n do v:=v+sqr (mas[i, j]) ;

    writeln ('Summa SQR=', v) ; {б}

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «8. Дан двумерный массив. Определить: А) сумму всех элементов массива; Б) сумму квадратов всех элементов массива. ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Хотя бы 3-4 задачи! 1) Дан одномерный целочисленный массив размерностью N. Найдите количество элементов, которые кратны 3 (5). 2) Дан одномерный целочисленный массив А, состоящий из N элементов. Найти сумму всех четных элементов массива.
Ответы (1)
Помогите решить задачи на паскаль. 1) Дан массив случайных чисел (количество элементов вводите с клавиатуры). Найти произведение всех элементов массива. 2) Дан массив случайных чисел (количество элементов вводите с клавиатуры).
Ответы (1)
дан массив из семи элементов написать программу подсчитывающую среднее второго и предпоследнего элементов массива дан целочисленный массив из 10 элементов написать программу находящую сумму элементов массива красных 3 ил 5 дан целочисленный массив
Ответы (1)
1) Дан массив из n элементов. Найти номер наименьшего элемента массива. 2) Дан массив из n элементов. Упорядочить массив по возрастанию. 3) Дан массив из n элементов. Упорядочить массив по убыванию.
Ответы (1)
1. Дан двумерный массив размером 3x5. Вычислить сумму элементов массива 2. Дан массив целых чисел размеров 4 х4. Заменить все элементы главной диагонали на нули. Вывести на экран монитора содержимое массива до обработки и после обработки 3.
Ответы (1)