Задать вопрос
22 июля, 11:16

Линейный массив содержит сведения о количестве осадков, выпавших за каждый из 12 месяцев одного года. Составить программу, определяющую общее количество осадков за этот год, среднемесячное количество осадков, количество засушливых месяцев (когда количество осадков было меньше 30 мм), самый засушливый месяц года. для Turbo Pascal.

+5
Ответы (1)
  1. 22 июля, 12:29
    0
    Program zadacha;

    var

    a: array [1 ... 12] of integer;

    i, o, k, z, j: integer;

    s:real;

    begin

    writeln ('vvedite kolichestvo osadkov') ;

    for I:=1 to 12 do

    read (a[I]) ;

    o:=0;

    for I:=1 to 12 do

    o:=o+a[I];

    writeln ('obshee kolichestvo osadkov=', o) ;

    s:=o/12;

    writeln ('srednee kolichestvo=', s:3:2) ;

    k:=0;

    for i:=1 to 12 do

    if a[I]<30 then k:=k+1;

    writeln ('kolichestvo zasushlivih=', k) ;

    j:=30;

    for I:=1 to 12 do

    if a[I] begin

    j:=[I];

    z:=I;

    end;

    writeln ('samiy zasusliviy mesyac=', z) ;

    readln;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Линейный массив содержит сведения о количестве осадков, выпавших за каждый из 12 месяцев одного года. Составить программу, определяющую ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Массив содержит сведения о количестве осадков выпавших за каждый из 12 месяцев. Найти: а) общее количество осадков за год; б) количество засушливых месяцев (
Ответы (1)
Напишите полностью программу в Turbo Pascal. Создать программу в Turbo Pascal ... Пользователь вводит n элементов массива. Требуется определить количество элементов, значение которых больше, чем у предыдущего элемента массива
Ответы (1)
В массиве хранятся сведения о количестве осадков, выпавших за 10 дней июня. Написать программу, которая определяет общее количество осадков за 10 дней. Массив должен вводиться во время работы программы.
Ответы (1)
1) В массиве хранятся сведения о количестве осадков, выпавших за январь. Определить: а) Общее количество осадков за январь;
Ответы (1)
Помогите решить задачи по turbo pascal. 1) Найти сумму элементов массива целых чисел в количестве 20 меньше данного числа 2. 2) Найти все элементы массива целых чисел в количестве 20 удовлетворяющие условиям остаток от деления на 5 равен 3.
Ответы (1)