Задать вопрос
1 января, 10:45

Массив содержит сведения о количестве осадков выпавших за каждый из 12 месяцев. Найти: а) общее количество осадков за год; б) количество засушливых месяцев (<30 мм).

+3
Ответы (1)
  1. 1 января, 14:37
    0
    Получите заспишитесь)

    const n=12;

    var i, k, l, o:integer; a:array [1 ... 100] of integer;

    begin

    writeln ('Введите кол-во осадков: ') ;

    for i:=1 to n do begin

    write ('За ', i,'-й месяц: ') ;

    readln (a[i]) ; l:=l+a[i];

    if a[i]<30 then inc (o) ;

    end;

    write ('О бщее количество осадков за год : ', l,' К оличество засушливых месяцев : ', o) ;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Массив содержит сведения о количестве осадков выпавших за каждый из 12 месяцев. Найти: а) общее количество осадков за год; б) количество ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Линейный массив содержит сведения о количестве осадков, выпавших за каждый из 12 месяцев одного года. Составить программу, определяющую общее количество осадков за этот год, среднемесячное количество осадков, количество засушливых месяцев (когда
Ответы (1)
В массиве хранятся сведения о количестве осадков, выпавших за 10 дней июня. Написать программу, которая определяет общее количество осадков за 10 дней. Массив должен вводиться во время работы программы.
Ответы (1)
1) В массиве хранятся сведения о количестве осадков, выпавших за январь. Определить: а) Общее количество осадков за январь;
Ответы (1)
1. Дан массив. Напечатать: а) Все четные 1. Дан массив. Напечатать: а) Все четные элементы б) Все элементы, оканчивающиеся нулем. 2. В массиве хранится информация о количестве осадков, выпавших каждый день января.
Ответы (1)
1. Дан массив. Напечатать: а) Все четные элементы б) Все элементы, оканчивающиеся нулем. 2. В массиве хранится информация о количестве осадков, выпавших каждый день января. Определить, в какие числа месяца осадков не было.
Ответы (1)