Задать вопрос
6 октября, 00:41

Написать программу, которая запрашивает массив из N элементов, а затем делает все элементы массива на минимальный элемент. Протестировать программу на массивах размерностью 5 и 10 элементов

+4
Ответы (1)
  1. 6 октября, 04:29
    0
    var i, N:integer;

    Min:real;

    mas:array[0 ... 100]of real;

    beegin

    write ('введите N') ;

    read (N) ;

    {for i:=1 to N do begin

    mas[i]:=random (50) ; write (mas[i],' ') ; end;

    или

    for i:=1 to N do

    read (mas[i]) ;

    for i:=1 to N do

    write (mas[i],' ') ; }

    min:=mas[0];

    for i:=0 to N do

    if min
    writeln;

    for i:=1 to N do begin

    mas[i]:=mas[i]/min; write (mas[i]) ; end;
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Написать программу, которая запрашивает массив из N элементов, а затем делает все элементы массива на минимальный элемент. Протестировать ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Написать программу, которая запрашивает массив размерности N и выводит на экран сам массив, а также наибольший и наименьший элементы массива. Протестировать программу на массивах размерностью 5 и 10 элементов.
Ответы (1)
1. Разработать схему алгоритма, который вводит массив из Nцелых чисел и выводит на экран этот же массив в прямом и обратном порядке. Протестировать алгоритм на произвольных массивах, состоящих из 1 числа, из 5 чисел, из 10 чисел. 2.
Ответы (2)
Хотя бы 3-4 задачи! 1) Дан одномерный целочисленный массив размерностью N. Найдите количество элементов, которые кратны 3 (5). 2) Дан одномерный целочисленный массив А, состоящий из N элементов. Найти сумму всех четных элементов массива.
Ответы (1)
1. Возвести в квадрат все элементы массива A. Размер массива и значения элементов массива - произвольные. 2. Увеличить на 4 все элементы в первой половине массива A (считать, что в массиве чётное число элементов).
Ответы (1)
доброго времени суток.) кто-нибудь может помочь? ибо я совсем не вывожу информатику. 1. Написать программу, которая вводит массив из N целых чисел и выводит на экран элементы с чётными номерами.
Ответы (1)