Задать вопрос
30 августа, 07:43

В массив вводят размеры n файлов (в байтах) от 100 до 9000. Преобразовать все значения превышающие 1024 байта в килобайты

+4
Ответы (1)
  1. 30 августа, 09:55
    0
    var a:array[1 ... 250] of string; size:real; i, n:integer; text:string;

    begin

    writeln ('daite N') ; readln (n) ;

    for i:=1 to n do

    begin

    readln (size) ;

    if (size>1024) or (size=1024) then

    begin

    size:=size/1024;

    str (size:0:2, text) ;

    a[i]:=text+' kb';

    text:=''; size:=0;

    end else

    begin

    str (size, text) ; a[i]:=text+' bytes'; text:=''; size:=0;

    end;

    end;

    for i:=1 to n do write (a[i],' ') ; readln;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «В массив вводят размеры n файлов (в байтах) от 100 до 9000. Преобразовать все значения превышающие 1024 байта в килобайты ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Составьте программу, которая осуществляет ввод в массив с клавиатуры размеров 5 файлов в байтах (от 100 до 9000 байт) и преобразует значения, превышающие 1024 байт, в килобайты. Результат выводится в строку.
Ответы (1)
На жестком диске было 12 папок, в 5 из них было по 8 файлов, а оставшихся по 10 файлов. После перегруппировки всех файлов стало 11 папок с равным количеством файлов. Количество файлов не изменилось.
Ответы (2)
В каком варианте объёмы памяти расположены в порядке возрастания? 1) 5 бит, 3 байта, 20 бит, 1 Кбайт, 1010 байт 2) 5 бит, 3 байта, 20 бит, 1010 байт, 1 Кбайт 3) 5 бит, 20 бит, 3 байта, 1 Кбайт, 1010 байт 4) 5 бит, 20 бит, 3 байта, 1010 байт, 1 Кбайт
Ответы (1)
Укажите упорядоченную по возрастанию последовательность значений Выберите один ответ: 1. 20 бит, 2 байта, 15 бит 2. 2 байта, 15 бит, 20 бит 3. 15 бит, 2 байта, 20 бит 4. 15 бит, 20 бит, 2 байта
Ответы (1)
Выразите в килобайтах: 1) 1024 байта 2) 2 (10) байта 3) 2 (13) байта 4) 2 (16) байтов 5) 2 (13) битов 6) 2 (16) битов 7) 0,25 Мбайт
Ответы (1)