Задать вопрос
8 июля, 09:55

Составьте программу, которая осуществляет ввод в массив с клавиатуры размеров 5 файлов в байтах (от 100 до 9000 байт) и преобразует значения, превышающие 1024 байт, в килобайты. Результат выводится в строку.

+2
Ответы (1)
  1. 8 июля, 13:42
    0
    var

    a:array[1 ... 5]of integer;

    i:integer;

    begin

    for i:=1 to 5 do read (a[i]) ;

    for i:=1 to 5 do write (a[i],' ') ;

    writeln;

    for i:=1 to 5 do if a[i]>=1024 then writeln (a[i] div 1024) ;

    writeln;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Составьте программу, которая осуществляет ввод в массив с клавиатуры размеров 5 файлов в байтах (от 100 до 9000 байт) и преобразует ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
В массив вводят размеры n файлов (в байтах) от 100 до 9000. Преобразовать все значения превышающие 1024 байта в килобайты
Ответы (1)
В порядке возрастания единицы измерения информации указаны в по- следовательности: 1) 1 килобайт, 2^20 байт, 1024 мегабайт 2) 2^10 килобайт, 1024 байт, 1 гигабайт 3) 2^10 байт, 1 терабайт, 1024 мегабайт 4) 2^20 байт, 1 мегабайт, 1024 килобайт
Ответы (1)
На жестком диске было 12 папок, в 5 из них было по 8 файлов, а оставшихся по 10 файлов. После перегруппировки всех файлов стало 11 папок с равным количеством файлов. Количество файлов не изменилось.
Ответы (2)
Вариант 1 1.3 Мбайт = ... Кбайт 2.1,5 Кбайт = ... байт 3.4096 бит = ... Кбайт = ... байт 4.5/128 Кбайт = ... байт = ... бит 5. 1/2 Кбайт 15 байт = ... байт 6.1024 бит + 2 байт = ... бит = ... байт
Ответы (1)
Задать массив из n элементов. Значения вести с клавиатуры. Написать программу, уменьшающую все элементы массива на единицу. Вывести на экран массив дважды; сначала исходный массив (в строку), а затем с новой строки - полученный массив.
Ответы (1)