Задать вопрос
4 октября, 21:32

Подсчитать количество строк заданной целочисленной матрицы N*N, являющихся перестановкой чисел 1,2, ..., N (вообщем нужно подсчитать кол-во строк в которых числа не повторяются)

за полноценное решение 34 пенкта.

+1
Ответы (1)
  1. 4 октября, 23:17
    0
    Program s;

    uses crt;

    const n=1;

    Var i, j, otvet, prov:integer;

    st:array[1 ... n] of string[n];

    a:array[1 ... n, 1 ... n] of integer;

    Begin

    For i:=1 to n do

    Begin

    For j:=1 to n do

    Begin

    a[i, j]:=random (n+1) ;

    Write (a[i, j],' ') ;

    End;

    Writeln;

    End;

    For i:=1 to n do

    For j:=1 to n do

    st[i]:=st[i]+inttostr (a[i, j]) ;

    For i:=1 to n-1 do

    begin

    For j:=i+1 to n do

    if st[i]st[j] then

    prov:=prov+1;

    if prov=n-i then otvet:=otvet+1;

    prov:=0;

    End;

    Writeln ('Ответ = ', otvet+1)

    End.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Подсчитать количество строк заданной целочисленной матрицы N*N, являющихся перестановкой чисел 1,2, ..., N (вообщем нужно подсчитать кол-во ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Для матрицы размером в n строк и m столбцов составить алгоритм и программу вычисления: 1) Сумм элементов каждой нечетной строки матрицы 2) Суммы произведений тангенсов элементов четных строк матрицы.
Ответы (1)
Задача на C++. Двумерный массив 5*5. Для каждой строки заданной матрицы определить и напечатать сумму элементов столбцов с чётными номерами. Для каждого столбца заданной матрицы найти и напечатать максимальный элемент.
Ответы (1)
поставьте знаки арифметических операций в каждой схеме. А) скорость? время=путь б) путь? время=скорость в) масса 1 батона? количество батонов=общ. масса г) кол. батонов? кол. буханок=общ. кол. д) кол. конфет в 1 коробке? кол. коробок = общ. кол.
Ответы (1)
Напишите программу, которая обнуляет все элементы квадратной матрицы, расположенные выше главной диагонали. Входные данные В первой строке записаны через пробел размер квадратной матрицы N (количество строк равно количеству столбцов) (1 ≤ N ≤ 100).
Ответы (1)
Из заданной целочисленной матрицы А (N, М) удалите строку в которой есть отрицательный элемент решить
Ответы (1)