Задать вопрос
24 октября, 14:33

Задача №1 Составить программу проверяющую является ли слово "перевертышем"

Задача №2 Подсчитать каких букв в предложении больше "а" или "е"

все в паскале

+5
Ответы (1)
  1. 24 октября, 15:59
    0
    var

    S:string;

    i:integer;

    begin

    write ('S = ') ;

    readln (S) ;

    for i : = 1 to Length (S) do

    if S[i] S[Length (S) - i + 1] then

    begin

    writeln ('No') ;

    readln;

    Exit;

    end;

    writeln ('Yes') ;

    readln;

    end.

    //вторая программа

    var

    S:string;

    i, countA, countE:integer;

    begin

    CountA : = 0;

    CountE : = 0;

    write ('S = ') ;

    readln (S) ;

    for i : = 1 to Length (S) do

    if S[i] = 'a' then

    inc (countA)

    else

    if S[i] = 'e' then

    inc (countE) ;

    if countA > countE then

    writeln ('a > e')

    else

    if countA < countE then

    writeln ('a < e')

    else

    writeln ('a = e') ;

    readln;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Задача №1 Составить программу проверяющую является ли слово "перевертышем" Задача №2 Подсчитать каких букв в предложении больше "а" или "е" ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы