Задать вопрос
27 сентября, 16:35

Pascal

Дан массив вещественных чисел. Найти сумму и количество отрицательных с нечетными номерами элементов, расположенных в первой половине массива (включая середину)

Ограничения:

-число элементов в матрице не более 10-ти

Порядок ввода исходных данных:

-число элементов в массиве

-элементы массива

Порядок вывода результатов:

-значение суммы с точностью до одного знака после запятой, ограничить ширину поля вывода результата 7-ю позициями, количество таких элементов или сообщение "Элементы не найдены"

+4
Ответы (1)
  1. 27 сентября, 19:08
    0
    var a:array[1 ... 10]of integer;

    n, i, k:integer;

    s:real;

    begin

    readln (n) ;

    for i:=1 to n do readln (a[i]) ;

    i:=1;

    while i<=n do begin

    if a[i]<0 then begin inc (k) ; s:=s+a[i]; end;

    i:=i+2;

    end;

    if k0 then writeln (s:0:7,' ', k) else writeln (' Элементы не найдены ') ;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Pascal Дан массив вещественных чисел. Найти сумму и количество отрицательных с нечетными номерами элементов, расположенных в первой ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
1. Возвести в квадрат все элементы массива A. Размер массива и значения элементов массива - произвольные. 2. Увеличить на 4 все элементы в первой половине массива A (считать, что в массиве чётное число элементов).
Ответы (1)
Составить программу на языке Паскаль: 1) Для массива K из 12 вещественных чисел определить сколько элементов массива меньше 0. 2) В массиве М из 10 целых чисел найти количество элементов равных 3.
Ответы (1)
Все задачи делаются в Паскале! 1) Увеличить все элементы массива A на 1. 2) Умножить все элементы массива A на 2. 3) Возвести в квадрат все элементы массива A.
Ответы (1)
Хотя бы 3-4 задачи! 1) Дан одномерный целочисленный массив размерностью N. Найдите количество элементов, которые кратны 3 (5). 2) Дан одномерный целочисленный массив А, состоящий из N элементов. Найти сумму всех четных элементов массива.
Ответы (1)
Помогите решить задачи на паскаль. 1) Дан массив случайных чисел (количество элементов вводите с клавиатуры). Найти произведение всех элементов массива. 2) Дан массив случайных чисел (количество элементов вводите с клавиатуры).
Ответы (1)