Задать вопрос
8 февраля, 16:46

Помогите написать программу в паскале. Задание: На плоскости даны 2 точки А (х1; у2) и В (х2; у2), определить какая из них находится дальше от начала координат. Я поняла, что нужно найти их длины (формулы я знаю), а правильно написать программу не могу

+5
Ответы (1)
  1. 8 февраля, 20:09
    0
    program prog;

    var x1, x2, y1, y2, i, b:integer;

    begin;

    writeln ('Введите 4 точки: x1, y1; x2, y2') ;

    readln (x1, y1, x2, y2) ;

    i:=abs (x1+y1) ;

    b:=abs (x2+y2) ;

    if i=b then writeln ('Координаты находятся на одной точке') else begin

    if i>b then writeln ('Первая координата дальше') else writeln ('Вторая координата дальше') ;

    end;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Помогите написать программу в паскале. Задание: На плоскости даны 2 точки А (х1; у2) и В (х2; у2), определить какая из них находится дальше ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Составить программу на языке паскаль: Две точки задаются своими координатами. Определите, какая из них находится дальше от: начала координат; окружности заданного радиуса с центром в начале координат.
Ответы (1)
1. Напишите программу вычисления корней квадратного уравнения, если с клавиатуры, если коэффициенты вводятся с клавиатуры (a, b, c) 2. Координаты 2-х точек плоскости вводятся с клавиатуры.
Ответы (1)
Даны координаты двух точек A (x1, y2) и B (x2, y2) в прямоугольной системе координат. Какая из этих двух точек находится дальше от начала координат?
Ответы (1)
Всё надо сделать на паскале. a) x^5 b) x^6 c) x^8 d) x^9 e) x^10 2 задание: Дан диаметр окружности d. Найти его длину (L=П*d) 3 задание: Найти длину окружности L и площадь круга S заданного радиуса R: L=2πR, S = πR^2 4 задание: Даны 2 числа a и b.
Ответы (1)
3) Выберите примеры декларативного знания: a) Я знаю, что арбуз - это ягода. b) Я знаю, как умножать в двоичной системе счисления. c) Я знаю, как смастерить скворечник. d) Я знаю, что Солнце - это звезда.
Ответы (1)