Задать вопрос
16 июля, 19:13

В одномерном целочисленном массиве определить среднее арифмитическое максимального и минимального чисел

+1
Ответы (1)
  1. 16 июля, 19:54
    0
    program massiv;

    var i, n, max, sr, min:longint;

    a:array[1 ... 1000]of longint;

    begin

    read (n) ;

    for i:=1 to n do

    read (a[i]) ;

    max:=-999999;

    min:=999999;

    for i:=1 to n do

    begin

    if a[i]>max then max:=a[i];

    if a[i]
    end;

    sr: = (max+min) div 2;

    writeln (sr) ;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «В одномерном целочисленном массиве определить среднее арифмитическое максимального и минимального чисел ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Паскаль. Вычислить разность максимального среди элементов, имеющих четные значения, и максимального среди элементов, имеющих нечетные значения, в заданном целочисленном массиве из 30 положительных элементов (в предположении, что в массиве есть и
Ответы (1)
Напишите программу вычисления разности максимального среди элементов, имеющих чётные значения, и максимального среди элементов, имеющих нечётные значения, в заданном целочисленном массиве из 10 положительных элементов (в предположении, что в массиве
Ответы (1)
1. в одномерном массиве найти значение и номер минимального элемента. 2. в одномерном массиве заменить все элементы кратные 3 на 0.
Ответы (1)
Составьте программу, выполняющую поиск минимального нечетного элемента в заданном целочисленном массиве из 50 элементов. Известно, что в массиве есть хотя бы один нечетный элемент.
Ответы (1)
Разработать алгоритм и программу поиска в одномерном массиве минимального и максимального числа. На экран выдать исходный массив, значения и индексы всех чисел, равных максимальному и минимальному элементам массива.
Ответы (1)