Задать вопрос
13 августа, 21:29

дан одномерный массив из 10 элементов определите среднее значение стоящих между минимальным и макимальным

+4
Ответы (1)
  1. 14 августа, 00:46
    0
    program massiv;

    var i, n, max, sr, min, pozm, pozx:longint;

    a:array[1 ... 10]of longint;

    begin

    for i:=1 to 10 do

    read (a[i]) ;

    for i:=1 to 10 do

    begin

    if a[i]>max then begin max:=a[i]; pozm:=i; end;

    if a[i]
    end;

    for i: = pozx+1 to pozm-1 do

    sr:=sr+a[i];

    sr:=sr div (pozm-pozx) ;

    writeln (sr) ;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «дан одномерный массив из 10 элементов определите среднее значение стоящих между минимальным и макимальным ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Хотя бы 3-4 задачи! 1) Дан одномерный целочисленный массив размерностью N. Найдите количество элементов, которые кратны 3 (5). 2) Дан одномерный целочисленный массив А, состоящий из N элементов. Найти сумму всех четных элементов массива.
Ответы (1)
1. Дан одномерный массив из N элементов. Заменить в нем значение макс и мин элемента на сумму всех элементов массива 2. Дан одномерный массив из Н элементов. Найти среднее арифметическое положительных четных элементов данного массива
Ответы (1)
дан массив из семи элементов написать программу подсчитывающую среднее второго и предпоследнего элементов массива дан целочисленный массив из 10 элементов написать программу находящую сумму элементов массива красных 3 ил 5 дан целочисленный массив
Ответы (1)
1) Дан одномерный массив А[N], - целых чисел. Заменить все большие 7 члены массива числом 7. Найти количество таких членов. 2) Задан массив из 10 элементов, найти произведение элементов массива. Задача №3.
Ответы (1)
1) Дан массив из n элементов. Найти номер наименьшего элемента массива. 2) Дан массив из n элементов. Упорядочить массив по возрастанию. 3) Дан массив из n элементов. Упорядочить массив по убыванию.
Ответы (1)