Задать вопрос
13 октября, 00:28

У школьников было S рублей. Бутылка с соком стоит P рублей, пустая бутылка стоит B рублей. Напишите программу, вычисляющую, сколько бутылок сока могут выпить ученики, если они сдают пустые бутылки и на вырученные деньги и на деньги, оставшиеся от предыдущей покупки, покупают бутылки с соком. (На Паскале)

+2
Ответы (1)
  1. 13 октября, 00:38
    0
    program zadacha_1;

    var

    s, p, b : real;

    n : integer;

    begin

    n : = 0;

    writeln ('Введите количество денег у школьника пример: (10.00) ') ;

    read (s) ;

    writeln ('Введите стоимость сока пример: (10.00') ;

    read (p) ;

    writeln ('Введите стоимость бутылки пример: (10.00') ;

    read (b) ;

    while s>=p do

    begin

    n : = n + 1;

    s : = s - p;

    s : = s + b;

    end;

    writeln ('Можно купить ', n, ' бутылок сока.') ;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «У школьников было S рублей. Бутылка с соком стоит P рублей, пустая бутылка стоит B рублей. Напишите программу, вычисляющую, сколько бутылок ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Задание #1 Напиши программу, вычисляющую периметр и площадь прямоугольника. Используй для этого длину и ширину прямоугольника, которые вводятся с клавиатуры.
Ответы (1)
1. Написать программу, вычисляющую сумму отрицательных чисел, кратных 5, среди пяти, вводимых с клавиатуры. 2. Написать программу, вычисляющую произведение чисел, оканчивающихся цифрами 2 и 4, среди пяти, вводимых с клавиатуры. 3.
Ответы (1)
Умоляю, помогите с Паскалем 1. Пользователь вводит неотрицательное однозначное число A. Написать программу: вычисляющую в случае ввода 1 - площадь круга с радиусом A, вычисляющую в случае ввода 2 - площадь квадрата со стороной A, вычисляющую в
Ответы (1)
1. написать программу, вычисляющую значение функции y=x-24 2. написать программу, вычисляющую значение функции (y=f (x)) y=x-2, если x>0, y=0, если x=0, y=x*x, если x
Ответы (1)
Напишите программу (в паскале авс), которая вычисляет число пи с заданной пользователем точностью. Воспользуйтесь данными и условием предыдущей задачи.
Ответы (1)