Задать вопрос
27 января, 05:17

Дано натуральное число N и последовательность а1, а2, ..., аN натуральных чисел, заданных с клавиатуры. Определить количество и сумму элементов этой последовательности, имеющих чётные порядковые номера и являющихся нечётными числами. Решить задачу для N=10 (Написать на Паскале).

+5
Ответы (2)
  1. 27 января, 05:56
    0
    const

    n=10;

    var

    a:array [1 ... n] of integer;

    i, k, sum:integer;

    begin

    k:=0;

    sum:=0;

    for i:=1 to n do

    begin

    write ('A[', i,'] = ') ;

    readln (a[i]) ;

    if (i mod 2 = 0) and (a[i] mod 2 0) then

    begin

    k:=k+1;

    sum:=sum+a[i];

    end;

    end;

    writeln ('Summa: ', sum) ;

    writeln ('Kol-vo: ', k) ;

    readln;

    end.
  2. 27 января, 08:52
    0
    program a;

    uses crt;

    var i, n, sum, qty:integer;

    a:array [1 ... 10] of integer;

    begin

    clrscr;

    n:=10;

    sum:=0;

    qty:=0;

    for i:=1 to n do begin

    readln ('a[', i.']=', a[i]) ;

    end;

    for i:=1 to n do begin

    if i mod 2 = 0 then

    if a[i] mod 2 0 then

    sum:=sum+a[i];

    inc (qty) ;

    endif;

    endif;

    end;

    writeln ('Сумма составила ', sum) ;

    writeln ('Количество составило ', qty) ;

    readkey;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Дано натуральное число N и последовательность а1, а2, ..., аN натуральных чисел, заданных с клавиатуры. Определить количество и сумму ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
2. Дан массив из N элементов. Определить количество элементов, имеющих четные порядковые номера и являющихся нечетными числами.
Ответы (1)
Помогите решить задачи на паскаль. 1) Дан массив случайных чисел (количество элементов вводите с клавиатуры). Найти произведение всех элементов массива. 2) Дан массив случайных чисел (количество элементов вводите с клавиатуры).
Ответы (1)
Free pascal! Дан массив определенной длины. Проинициализировать массив и найти количество элементов массива, имеющих четные порядковые номера, но являющиеся нечетными числами.
Ответы (1)
1. Напишите программу, которая в последовательности натуральных чисел определяет количество чисел, кратных 4. Программа получает на вход количество чисел в последовательности, а затем сами числа. В последовательности всегда имеется число, кратное 4.
Ответы (1)
Помогите решить через паскаль 1) массив А вводится с клавиатуры, найти среднее арифметическое его элементов с нечетными номерами, размер произвольный.
Ответы (1)