Задать вопрос
27 августа, 05:01

10.45 Даны первый член и разность арифметическое прогрессии. Написать рекурсивную функцию для нахождения а) n-ого члена прогрессии. б) суммы первых n членов прогрессии.

+4
Ответы (1)
  1. 27 августа, 07:18
    0
    var

    a, b: real;

    n: integer;

    function arif_mem (a, b: real; n: integer) : real;

    begin

    if n = 1 then arif_mem : = a;

    if n > 1 then arif_mem : = arif_mem (a, b, n - 1) + b;

    end;

    function arif_sum (a, b: real; n: integer) : real;

    begin

    if n = 1 then arif_sum : = a;

    if n > 1 then arif_sum : = arif_sum (a, b, n - 1) + arif_mem (a, b, n) ;

    end;

    begin

    write ('введите первый член прогрессии:') ;

    readln (a) ;

    write ('введите разность прогрессии:') ;

    readln (b) ;

    write ('введите номер члена прогрессии:') ;

    readln (n) ;

    writeln (n, '-й член прогрессии равен : ', arif_mem (a, b, n) : 8:2) ;

    writeln ('сумма ', n, ' членов прогрессии равна : ', arif_sum (a, b, n) : 8:2) ;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «10.45 Даны первый член и разность арифметическое прогрессии. Написать рекурсивную функцию для нахождения а) n-ого члена прогрессии. б) ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Даны первый член и разность арифметической прогрессии. Написать рекурсивную процедуру для нахождения $n$-го члена прогрессии и суммы первых $n$ членов.
Ответы (1)
1. дано действительное число x и целое число n вывести N первых челнов арифметическойкой прогрессии и найти сумму ее первых членов если первый член X а разность 1,12 2.
Ответы (1)
Заданы первый член арифметической прогрессии а, разность прогрессии d и количество членов прогрессии k. Вычислить k-1 и к-ые члены арифметической прогрессии и сумму первых n членов Sn.
Ответы (1)
Напишите рекурсивную и не рекурсивную функции вычисляющие НОД двух натуральных чисел с помощью модифицированного алгоритма евклида
Ответы (1)
Напишите рекурсивную функцию вычисления суммы цифр натурального числа. Формат входных данных На вход ваша программа получает одно натуральное число n (n
Ответы (1)