Задать вопрос
18 ноября, 19:59

Даны первый член и разность арифметической прогрессии. Написать рекурсивную процедуру для нахождения

$n$-го члена прогрессии и суммы первых $n$ членов.

Формат входных данных

В первой строке входного файла содержатся 3 целых числа $n$, $1 / le n / le 100$, первый член прогрессии

$a_1$, $/mid a_1 / mid / leq 100$ и разность прогрессии $d$, $/mid d / mid / leq 100$.

Формат выходных данных

Выходной файл должен содержать два числа - $n$-й член прогрессии и сумму первых $n$ членов.

Примеры:

Вход

5 34 - 2

Выход

26 150

+3
Ответы (1)
  1. 18 ноября, 22:06
    0
    Var n, a1, d, an, s:integer;

    procedure p (n, a1, d:integer; var an, s:integer) ;

    begin

    if n>1

    then begin p (n-1, a1, d, an, s) ; an:=an+d; s:=s+an; end

    else begin an:=a1; s:=a1; end;

    end;

    begin

    writeln ('n, a1, d:') ;

    readln (n, a1, d) ;

    p (n, a1, d, an, s) ;

    writeln ('an = ', an,' s = ', s) ;

    end.

    Пример:

    n, a1, d:

    5 34 - 2

    an = 26 s = 150
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Даны первый член и разность арифметической прогрессии. Написать рекурсивную процедуру для нахождения $n$-го члена прогрессии и суммы первых ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Задача W. Сумма двух чисел Имя входного файла: sum. in Имя выходного файла: sum. out Ограничение по времени: 2 секунды Ограничение по памяти: 256 мегабайт Формат входного и выходного файла На первой строке входного файла находятся два целых числа a
Ответы (1)
Задача D Три числа Дан массив из N целых чисел а1, а2, ..., an. Вам нужно проверить, есть ли в этом массиве три числа сумма которых равна нулю. Формат входных данных В первой строке входного файла содержится одно целое число N (1 ≤ N ≤ 2000).
Ответы (1)
Задача D Нечет Задано два целых числа A и B. Найдите сумму нечетных чисел от A до B. Формат входных данных Первая строка входного файла содержит два целых числа A и B (1 < = A, B < = 10^9). Формат выходных данных Выведите ответ к задаче.
Ответы (1)
Имя входного файла: стандартный ввод Имя выходного файла: стандартный вывод Ограничение по времени: 1 секунда Ограничение по памяти: 256 мегабайт У Жарасхана есть массив а из n чисел, к каждому числу массива Жарасхан должен применять лишь одну
Ответы (1)
Дан массив из N целых чисел a1, a2 ..., aN. Вам нужно проверить, есть ли в этом массиве три числа сумма которых равно нулю. Формат входных данных В певой строке входного файла содержится одно целое число n (1
Ответы (1)