Задать вопрос
19 декабря, 17:03

Нужно решить задачку:

Найти максимальное и минимальное число

(Блок схема и программа)

Работаем в Паскале

+4
Ответы (1)
  1. 19 декабря, 17:18
    0
    если водится n чисел то вот программа

    program maxmin;

    var a:array[1 ... 1000]of longint;

    i, n, max, min:longint;

    begin

    read (n) ;

    for i: = 1 to n do

    read (a[i]) ;

    min:=a[1];

    max:=a[1];

    for i:=1 to n do

    begin

    if a[i]
    if a[i]>max then min:=a[i];

    end;

    writeln ('min=', min,'max=', max) ;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Нужно решить задачку: Найти максимальное и минимальное число (Блок схема и программа) Работаем в Паскале ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Y={0, если х≤0 х, если 0
Ответы (1)
1) Вычислить длину окружности и площадь круга одного и того же заданного радиуса R. Pascal (желательно с блок-схемой) 2) Найти сумму членов арифметической прогрессии, если известны её первый член, знаменатель и число членов прогрессии Pascal
Ответы (1)
Помогите сделать программу в Паскале В котором 1) Программа выдает сообщение "Вы маль или дево" 2) Пользователь в переменную ST1 задает значение маль или дево 3) Программа выдает сооб "Ты пошла бы играть в куклы" 4) Вводить ответ через переменную
Ответы (1)
1. Напишите программу, которая в последовательности натуральных чисел определяет количество чисел, кратных 4. Программа получает на вход количество чисел в последовательности, а затем сами числа. В последовательности всегда имеется число, кратное 4.
Ответы (1)
Напишите программу, которая в последовательности натуральных чисел определяет минимальное положительное число, кратное 5. Программа получает на вход количество чисел в последовательности, а затем сами числа.
Ответы (2)