Задать вопрос
3 января, 01:01

Напишите программу, которая в последовательности натуральных чисел определяет минимальное положительное число, кратное 5.

Программа получает на вход количество чисел в последовательности, а затем сами

числа. В последовательности всегда имеется положительно число, делящееся нацело на 5.

Количество чисел не превышает 100. Введенные числа по абсолютной величине

не превышают 30 000.

Программа должна вывести одно число - минимальное положительно число, кратное 5.

Входные данные:

4

-5

10

6

25

Выходные данные:

10

Программу надо на Паскале.

+1
Ответы (2)
  1. 3 января, 03:34
    0
    var a:array[1 ... 100] of integer;

    k, i, Min:integer;

    begin

    Min:=30001;

    write ('Введите кол-во чисел ') ;

    Read (k) ;

    For k: = 1 to k do

    begin

    write ('Введите число ') ;

    Read (i) ;

    if (i mod 5 = 0) and (i 0) then

    Min:=i;

    end;

    Write ('Ответ - > ', Min) ;

    end.
  2. 3 января, 04:35
    0
    Var

    A, Min:integer;

    N:byte;

    Begin

    Min:=30001;

    Read (N) ;

    For N: = 1 to N do

    Begin

    Read (A) ;

    if (A>0) and (A mod 5 = 0) and (A < Min) then Min:=A;

    End;

    Write (Min)

    End.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Напишите программу, которая в последовательности натуральных чисел определяет минимальное положительное число, кратное 5. Программа ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
1. Напишите программу, которая в последовательности натуральных чисел определяет количество чисел, кратных 4. Программа получает на вход количество чисел в последовательности, а затем сами числа. В последовательности всегда имеется число, кратное 4.
Ответы (1)
Напишите программу, которая в последовательности натуральных чисел определяет минимальное число, делящееся нацело на 7. Программа получает на вход количество чисел в последовательности, а затем сами числа.
Ответы (1)
1) Напишите программу которая в последствии натуральных чисел определяет, находит сумму двузначных чисел не кратных 4. В последовательности обязательно имеется двузначное число не кратное 4.
Ответы (1)
1) Напишите программу которая в последствии натуральных чисел определяет, есть ли в последовательности нечетные числа не оканчивающихся на 1. Вход: программа получает на выход кол-во чисел, а затем сами числа.
Ответы (2)
Напишите программу, которая в последовательности натуральных чисел определяет минимальное число, кратное 3. Программа получает на вход количество чисел в последовательности, а затем сами числа. В последовательности всегда имеется число, кратное 3.
Ответы (1)