Задать вопрос
15 июля, 22:13

Помоите решить. Циклы (паскаль). В послед a1, a2, a3, ... an каждый член, начиная с четвёртого, равен последней цифре суммы трёх предыдущих. Найти n-ый элемент последовательности. Да хотелось бы еще чтобы каждая строчка была расписана что в ней происходит.

+5
Ответы (1)
  1. 15 июля, 23:48
    0
    uses crt; {Подключение внешнего модуля}

    var {Описание переменных}

    a:array [1 ... 100] of integer;

    n, i:integer;

    begin

    write ('n=') ; {Вывод текста на экран}

    read (n) ; {Чтение текста}

    for i:=1 to 3 do

    a[i]:=random (51) ; {Значение первых 3 элементов}

    for i:=4 to n do

    a[i]: = ((a[i-1]+a[i-2]+a[i-3]) mod 10) ; {Значение остальных элементов}

    writeln ('Последовательность:') ; {Вывод текста на экран}

    for i:=1 to n do

    write (a[i],' ') ; {Вывод последовательности на экран}

    writeln; {Перевод указателя на следующую строку}

    write ('N-ный элемент: ', a[i]) ; {Вывод текста и элемента на экран}

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Помоите решить. Циклы (паскаль). В послед a1, a2, a3, ... an каждый член, начиная с четвёртого, равен последней цифре суммы трёх ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Ввести слово и число раз (Ввод; паскаль, 3). Вывести это слово так: паскаль паскаль паскаль паскаль паскаль паскаль
Ответы (1)
Помоги решить. Задача по массивам (паскаль). В спортивных соревнованиях 10 судей выставили свои оценки спортсмену.
Ответы (1)
Для заданного числа N распечатать числовую последовательность, в которой каждый следующий элемент последовательности определяется через предыдущий элемент р, и равен: Вычисления прекратить, когда очередной элемент последовательности станет равен 1.
Ответы (1)
Паскаль! Написать программу, в которой по последней цифре числа определить последнюю цифру его квадрата и последнюю цифру его куба. Для определения последней цифры числа применить операцию MOD (получение остатка от деления).
Ответы (1)
Дан массив на 9 элементов. Первый элемент равен квадрату текущего индекса, увеличенному на 5. Второй элемент равен целой части квадратного корня из предыдущего элемента. Третий элемент равен сумме двух предыдущих элементов
Ответы (1)