Задать вопрос
11 марта, 23:32

Для заданного числа N распечатать числовую последовательность, в которой каждый следующий элемент последовательности определяется через предыдущий элемент р, и равен:

Вычисления прекратить, когда очередной элемент последовательности станет равен 1. (Известно, что в любой такой последовательности рано или поздно встречается 1).

Входные данные: Дано целое число N (1 ≤ N ≤ 100).

Выходные данные: В единственной строке вывести последовательность до 1.

Пример:

Входные данные

Выходные данные

7

7 22 11 34 17 52 26 13 40 20 10 5 16 8 4 2 1

+5
Ответы (1)
  1. 12 марта, 02:34
    0
    Буду считать что нечетные умножаются на 3 и прибавляется 1, четные делятся на 2

    i, k, n:integer;

    a:array[1 ... 10000] of integer;

    begin

    assign (input,'input. txt') ;

    reset (input) ;

    assign (output,'output. txt) ;

    rewrite (output) ;

    read (n) ;

    a[1]:=n;

    k:=1;

    while a[k]1 do

    if (a[k] div 2) = 0 then begin a[k]:=a[k] div 2; k:=k+1; end

    else begin a[k]:=a[k]*3+1; k:=k+1; end;

    for i:=1 to k do

    write (a[i],' ') ;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Для заданного числа N распечатать числовую последовательность, в которой каждый следующий элемент последовательности определяется через ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Помогите решить! 1))) Вводятся 4 числа: a, b, c и d. Выведите все числа на отрезке от a до b, дающие остаток c при делении на d Входные данные 1 4 1 2 выходные данные 1 3 Входные данный 1 5 0 4 выходные данные 4 2))) Выведите все числа на отрезке от
Ответы (1)
Уровень B. Задача M. Две одинаковые цифры рядом Напишите программу, которая определяет, верно ли, что введённое число содержит две одинаковых цифры, стоящие рядом (как, например, 221). Входные данные Входная строка содержит одно натуральное число.
Ответы (1)
Входные данные Вводится натуральное число N, которое не превосходит 30. Выходные данные Вычислите 1+2+22+23+ ...+2 N. Примеры входные данные 1 выходные данные 3 входные данные 4 выходные данные 31
Ответы (1)
Выведите все натуральные делители числа x в порядке возрастания (включая 1 и само число). Входные данные Вводится натуральное число x Выходные данные Выведите все делители числа x Примеры входные данные 7 выходные данные 1 7 входные данные 21
Ответы (1)
Задача 1 - Дано целое число. Если оно положительное, вывести " Число положительное ", если отрицательное вывести "Число отрицательное ", если равно 0 - "Число равно нулю" задача 2 - дано целое число.
Ответы (1)